Slow download speed / Stops at 95%

i have uinstalled and trying to install Warzone again and now my download speed drops at 95% so i takes forever. have 500/500 fiber and i have tried switching regions aswell to see if it bumps up the speed and dont help.

if the installation is stalling at 95% that is typically some sort of firewall or permission issue as that is the point where the Desktop Application needs proper permissions to complete the installation tasks. Its not likely anything wrong with the connection but an issue where a security program, firewall or Windows itself is not allowing the update agent to make the necessary changes to the installation in order for the install to complete.

Temporarily disabling firewalls, security software and other potential software conflicts may help. You may consider making a new windows administrator account and seeing if that addresses the permission issue: Creating a New Administrator Account - Blizzard Support

it goes from 60 MB/s to 400 KB/s stuck at 99% im guessing it will be finished at new year. I have never had any problems downloading/updating games before. It started with an error opening app and games, re-installed battle.net and then Warzone.

Hey i got the same thing. My speed is 200mb and it downloads games now only in 800kbs.

I completely disabled my security measures and it solved nothing.

i did try heartstone downloads like normal but vanguard ja warzone dont work.

I’m sorry, but i am also getting this problem on a fresh install of Windows with no security software installed, firewall and defender disabled and i also tried three different internet connections in three different locations. What am i supposed to do next?

Also having this issue. WoW install starts fine, then slows to a crawl and eventually stops. Each attempt stops at different completion percentage points.

Restarts, disabling security features, nothing fixed the issue.

Also on a rather fresh install of Windows 11 but no problems till today.

Bump! I can not get past 98% on MW2 beta. I’ve checked permissions and all is fine. Keeps saying I have 19.2gb of 19.2gb @43mbs. I have submitted a ticket but this beta only lasts a couple days so a sense of URGENCY would be appreciated…

2 Likes