Script error-Diablo II Installer [object KEY]-wont allow CD KEY on Install

I’ve tried all the different install methods [re-downloads, restarts,reinstall]-including starting in “Safe Mode” with networking to Install this game, but each time it has script errors [digital web downloader] which prevent moving forward with the install-based on invalid KEY.
Script error:
Line: 145
Character : 1
Error: Object doesn’t support property or method ‘keys’
Code: 0
URL: https://www.blizzard.com/en-us/store/downloaders/panes/d2.htm

Followed by 2 more error panels/on scripts via download store url’s.

I seem to have wasted my money here, sincerely frustrated…
Khaos Hjann

Hey, KhaosHjann! This is a display bug with the Installer on Windows 10 systems. Clicking Yes or No a few times should get rid of the script error. Once it’s cleared, select where you’ll be installing Diablo II.

This error should not impact the installation in anyway. If you continue to have issues installing, please contact our Technical Support team.

Hello Caterpepi,
It DOES effect install!
Cannot load CD Keys-the Object ‘KEY’ aspect of the download script apparently prevents it. Even after clearing the messages as you say. The following install window will keep giving you invalid key errors - thus no install can take place!
I’m using Windows 8.1 Pro, have disabled virus apps, tried alt. methods - to no avail.
I sincerely am frustrated with this unusable purchase!
And now you want me to pay again, for a help ticket!
No thanks…

1 Like

Thanks for following up with us and clarifying! It shouldn’t require payment to contact our support team. It sounds a bit like there may be some CD Key issues that we’ll want to work with you on. Could you try this link instead? If you can include any screenshots for the invalid key issue and the object key issue that you’re running into!

I also have this problem and cannot find any help solving it. Just another case of blizzard stealing my money and telling me to thank them for it. The help system is horrid, and when you do get anyone to talk to you they don’t help. They would sooner spit in your face. Sure am glad I wasted my money on this woo boy fun fun fun.

Cwatzy,

I’ve installed Diablo 2 several times in the last year without any issues, so it must work in general.

If it is not working for you, try the support link that Caterpepi provided right above you. And leave the hyperbole out the correspondence as it will only muddle the process making it unnecessarily difficult.

i have also gotten the installer working in windows 10. the scripting errors is only in the installer downloaded from battle.net. the disc installer have no issues.

2 Likes

Hello, I have the same issu then andreasasp on windows 10

The way to fix this is to go into your blizzard account after you enter your key into the website. Under games and subscriptions is will give you a new key that is longer than the original one and that one will work for the downloaded install.

See my reply to cwatzy.

The installer gives me invalid path errors unless I run it as an administrator. If you haven’t tried that, give it a shot.

1 Like

Running the download app as admin clear all errors that happened to me just now.

blizzard in its usual form nothing ever works properly what a joke

Hola.
Compré el juego Diablo II, pero luego de instalarlo, no lo puedo jugar. Tengo Windows 10 y no entiendo el porqué no puedo jugar, si la lo instalé correctamente.
Ayuda por favor.

P.d.: no sé que hacer para que me devuelvan el dinero.

You may have old registries on your PC which will cause that error and subsequent window flashing. You can search and remove any of these via regedit.

hola equipo de blizzard no puedo abrir el juego ya se descargo y abre pero al poner jugar no deja lo compre en linea no en cd pero no puedo jugar me puedan ayudar me aparece primero error en el script de esta pagina linea 137 caracter 1 error el objero no acepta la propiedad o el metodo keys