Scan and Repair feature broken?

I recently used the ‘Scan and Repair’ function for World of Warcraft because I kept getting a very annoying message saying that I have an active summon already to see if that did the trick, but unfortunately, this renders my WoW fully unplayable in the process until the scan (and repairs if there was any) fully succeeds without failure. Please help!

Hey, D00MBR1NG3RZ! What issues are you running into with the Scan and Repair? Is it looping or doing a repair after closing or opening up the Blizzard Application? Are there any errors that appear?

Recently, we have seen some issues with the 8.3.7 patch with the repair scans and the BB8 error. The most consistent thing that we’ve found to resolve these issues is to uninstall the game, delete the WoW installation folder, then reinstall the game. It’s not ideal by any means, but if the symptoms seem to match, its worth a try.

It happens to be looping time and again unfortunately, even if I closed and re-opened the Battle.net app.

D00MBR1NG3RZ,

I’d try the game reinstall that Caterpepi suggested. If it fails, usually that means there is a permission error. Temporarily uninstall any security you’re running and try doing the reinstall from a new admin account if you get any errors.

I have done everything Caterpepi suggested to me, and it worked like a charm. Thanks for the help! Looks like I won’t touch that ‘Scan and Repair’ function again anytime soon…

Glad to hear that worked, D00MBR1NG3RZ! It was just a hiccup with the latest patch that we’ve recently seen, but it should be pretty rare for this to happen.