Re-enable social settings marked as required

When attempting to log in to Battle.net moblie app, I am prompted with a message:
“Update your privacy settings to continue using the app To regain access to this app, re-enable the social settings marked as required in your Account Settings” and then it lists a link for “Visit Account Settings”. I click the link and it takes me to my settings page but does not highlight WHICH SETTINGS ARE REQUIRED FOR THE MOBILE APP TO WORK.

I still have my old keychain authenticator. That thing worked 100% of the time with not a single issue until the battery expired. Then we switched to the Authenticator app, which worked fine. Now we’re being asked to move to the Battle.net app and I’m now stuck having no authenticator; neither the old Authenticator app nor the newer Battle.net app are working for me.

Social Settings:
Text Chat - disabled - I don’t want people sending me chat requests.
Private Text Chat - on
Voice Chat - off
Friends - disabled - I don’t have any friends, so no need to “manage friendships” in a mobile app.
Friends of Friends Suggestions - disabled - seriously? This is a privacy concern.
Real ID - disabled - yeah, I don’t care to have my real name displayed publicly
Battle.net Groups - disabled - I don’t want to create or receive invitations to join chat groups.
Share Game Data - disabled - hey, I wonder if this one is one of the ‘required’ social settings for this app to work. Would sure be nice if Blizzard would mark them as such, as the app message indicates.
Communication Preferences - everything disabled - I don’t want sms and push notifs , or spam to my email.
Profile Visibility - Only Me - Maybe this is why I have no friends. I like it this way.

Update: Enabling “Share Game Data” did not fix the problem. I’m not going to, by trial and error, keep attempting. Blizzard should do a little work to streamline the process (like actually MARK which settings are required, since the app message says they have them marked).

2 Likes

I have exactly the same problem. I now no longer have a working authenticator (seriously, what’s wrong with SMS codes? you use them for some things like attempting to disconnect or re-connect this app, but the app is just useless).

I have slightly different socials settings, but broadly similar to the above, BUT THE KEY ISSUE IS THE ERROR MESSAGE TELLS US TO ENABLE THE SETTINGS MARKED AS REQUIRED AND NONE ARE MARKED AS REQUIRED - or indeed marked with anything useful.

Frankly, I don’t want to be social with people on this app. I mainly play the older Blizzard games that DON’T have multiplayer. Why force us to be “social” if that’s not what we’re here for?

I had an issue with the previous authenticator which meant I could not access my account for 2 years. Now that is fixed and I can get back in, I’m being forced to use an app that seems to require me to engage in ways I don’t want to. Really not doing anything for customer loyalty here Blizzard.