"Permanent" Battle.Net / launcher error BLZBNTBNA00000005

On April 6th (2+ weeks ago) seemingly out of nowhere I tried to run the Battle.Net launcher in order to play WoW. After years of running it with no issues, this “sleeping Update Agent” error was all that was available on the left side of the launcher window.

For a little less than 2 days, I was able to directly run the ‘wow.exe’ file from the ‘_ retail _’ directory, and despite having to manually log in, for that short time I was still able to play. As of the following Tuesday (or maintenance / patch / reset day as I’m sure many know it as), due to updates I could no longer run it.

Searching online (official forums included), I found some possible solutions, which I tried. At some point during this testing - despite not having gone into the ‘_ retail _’ dir again - the ‘wow.exe’ file had vanished entirely. The rest of the WoW directory structure (as far as I could tell) was still intact. Might have been a corrupted update download, but I can’t be sure.

Fast forward to now: I had opened a ticket, and after some back-and-forth with the individuals who had responded, I was told to come here and post this. The BLZBNTBNA00000005 error is still omnipresent and nothing I do - including all the suggestions, steps and directives given to me by the Blizzard support staff - have achieved anything thus far. Not even an inkling of progress.

As I had replied to the support people, I have done the following (each point essentially an answer to the steps Blizzard gave multiple times):

  • everything that can be updated is; drivers, OS, etc. (I am still using Windows 10 due to the Win11 upgrade misidentifying my CPU)
  • security scans have been done, and are run regularly anyway
  • exceptions have been added where possible in my security suite and set as split tunneled in the VPN (Blizzard’s own website claims BitDefender is “compatible”, and that is what I use for these solutions) - pretty much every .EXE I could find that appears in Task Manager with any relation to Blizzard or BattleNet has been added as split tunneled and excepted from any blockage
  • further to the above, I have also tried a number of times to repeat the install process with my security software completely disabled (something nobody should have to do, but here we are), which has made no difference to the outcome
  • a fresh new (admin) account was created as a test, and the issue persists exactly as it does for me normally
  • as of this forum post, BattleNet has been completely uninstalled and reinstalled 10 times, including the removal of temp files created by it in case those somehow retain any bad or corrupted info (such as the dirs that appear in %AppData%)

As an update to the ticket info, I have borrowed another PC (new, fresh Windows 11 install) and tried to install Battle.Net on it. The exact same error persists despite the OS being in fresh / “first run” condition, and no prior Blizzard software has ever touched the machine previous to my doing so for this test.

Looking in Task Manager, the Blizzard Update Agent is (seemingly randomly) either there but using no real resources except memory (zombie process, maybe?), or it disappears a short time after the Battle.Net main window spawns. This behavior is present on both machines I’ve mentioned, and yes, any and all Agent .EXEs are part of the split tunnel and exception lists. Same behavior with no security software active at all.

As stated, for years my setup had run Battle.Net and WoW without issue (well, I still have an in-game issue for which the ticket was closed prematurely due to “max replies” regarding my garrison being very, very broken, but that’s another story) including all the security software, so for this to suddenly appear out of nowhere, persist, and even jump hardware & OSes makes no sense to me.

If ANYONE can assist me with this, I’d be extremely grateful, as I’d really like to get back to enjoying WoW instead of paying for something I can’t even get into.

Thanks to any and all who can offer assistance.

Usually the features of a security suite like this persist outside of being disabled. For instance, the split tunneling will be something applied to your Windows network settings. I recommend completely uninstalling the software as a test, then trying Bnet. In most cases, this problem is simply caused by a failure of security software to keep up with definitions/security risks, despite users reporting it as the source of the issue.

Additionally, keep in mind that the article you’re referencing for BitDefender being “game friendly” is over 4 years old. The Bnet client and the games have gone through many updates, new version launches, and hotfixes since then.

I have the same issue. Tried absolutely everything. I haven’t been able to play any blizzard game for months. I haven’t purchased the latest WoW expansion for this very reason.
It is embarrassing and unbelievably sad that this is what Blizzard has come to. This company has had a reputation for excellence for years, and I’ve been loyal to you since highschool but those days are long gone. The fact that such a completely blocking error is not only allowed to persist, but also there is absolutely no useful help from the company to resolve it just boggles the mind.

All I wanted this evening at the end of a very long day after a very long week and very long months…was a game of hearthstone and you are denying me this littlest of pleasures.

1 Like

Like… you have to know how often this error happens. There is a link in the battlenet client that opens a useless landing page with useless instructions.
Please just go and measure the traffic to that page and you will have a clear and immediate idea of the magnitude of your failure and the disappointment you’re causing to this community and your loyal customers.
Shame

1 Like

Players in this forum (like myself) aren’t going to be able to pass on that feedback for you.

Right, so lemme start off by saying thank you for your effort in trying to help. As a community member who’s invested time in other peoples’ issues, what you’re doing is admirable, laudable, and a damn sight better than the company you’re helping because as of today they’ve just closed my ticket regarding this with zero progress towards resolution as if it were “resolved”. It very much is not, and I’m very much disgusted with that client mishandling.

I would also like to state any implied frustration or dissatisfaction that follows this preamble is in no way aimed at you, as I understand you are not a Blizzard employee and are offering your valuable time to work on their behalf (I’m guessing for nothing). That being said…

Severely against my better judgement as a mostly-retired ITSec professional who is using the most unstable, unreliable, fault-heavy and security hole-ridden OS ever made in a time where being connected to the internet is the most dangerous it’s ever been since DARPA decided to open the proverbial floodgates, I actually went ahead and did what you suggested.

Long story short: absolutely no change whatsoever. Same issue, same error, same still-can’t-use-what-I’m-paying-for. It has to be the fault of this Agent process, somehow.

Really, it shouldn’t matter whether the post regarding BD is 4 days old, 4 months, or 4 years. Once software claims compatibility with something essential to safe operation, it shouldn’t magically be able to revoke or pretend that it doesn’t have to be. Electronic security, online, isn’t some new as-yet-unstandardized thing; there’s no excuse for any company or product to not comply with working alongside the things we use to stay safe online. If the launcher failing to play nice with a VPN is the cause for some as I’ve read, that’s entirely on Blizzard to rectify. You wouldn’t suggest someone leave all their doors unlocked and windows open when they go away on vacation, right? Same thing here. Completely ditching all security measures to play one single uncooperative game shouldn’t even be on the table as a possibility. It’s… insane, don’t you agree?

Anyway, thanks again for trying, and if you have anything else I’m all ears. It’d be nice to play again… if that’s ever gonna be possible.

I agree that Blizzard has a lot of documentation that needs updating.

Looks like some players solved this 6 years ago on Reddit.

https://www.reddit.com/r/Blizzard/comments/7orgm0/error_blzbntbna00000005/

Before opening the ticket, I had already caught that Reddit posting and its’ subsequent links. The instructions they provide were a small piece of the 5-ish steps I was repeatedly given by Blizzard, and as such they were tried multiple times. Uninstall-reinstalls and the removal of the handful of temp and / or cache directories the Battle.Net launcher creates are something that has been done - in total now - around 16 times across 2 different PCs and versions of Windows.

This method does nothing to progress a solution for me, which is backed by evidence from the “fresh” install done on a second machine that had a brand new, first boot copy of Windows 11 as well as never having had any Blizzard software on it - since the problem happened immediately upon the first time the launcher was installed and run, there’s no way any previous files or information could have had any effect on the Agent failing whatsoever. It immediately repeated on a new install of Windows 11 exactly the same error and behavior it had been doing on my Windows 10 machine. This would indicate cached information or previously created files have nothing to do with the error or the issue.

So… thus far, we can rule out the following as “clear”, or not part of the problem due to repeated testing with no change:

  • uninstalling & reinstalling Battle.Net
  • Blizzard / Battle.Net directories located in places such as %AppData% and %ProgramData% containing any kind of bad / corrupt / outdated / incorrect information
  • firewall / VPN / internet security blocking or interfering with Battle.Net’s ability to do its’ intended function or hamper its’ communication with Blizzard servers & resources

This - to me, at any rate - shows that the problem is within the functionality of the Agent processes themselves. It could mean:

  • a failure of the Agent to communicate with the local Battle.Net application itself
  • a failure of the Agent in communicating with the Battle.Net servers / services on the remote end and hanging due to awaited responses that don’t happen
  • the Agent is just plain bugged
  • there is some sort of (partial?) error within the Agent code or comms protocol that somehow fails due to some unknown circumstance

…but I lack the technical (in-house) knowledge of the inner workings of this core process to really diagnose it properly. What I do know is launcher errors (specifically, those that prevent users from updating or playing titles) like BLZBNTBNA00000005 are extremely common by all that I have been reading, and those repeated reports are most likely not due to multitudes of individual users’ local machine issues and probably the lowest common denominator which would be the process itself being the origin of the fault.

Losing hope here, but I do appreciate your continued attempts. Thanks.

Maybe it’s something on the home network causing a block? I understand it’s a frustrating issue, but I can’t replicate the error to really investigate more from my PC. In truth, I have yet to encounter a Bnet problem like this one in over a decade.

Same problem here for the same amount of time, just different games. Nothing I seem to do fixes the problem. It is not a problem on our end. It is a them problem…

1 Like

I am unable to find anything that could possibly be blocking anything Blizzard-related, especially after trying your suggestion of removing the entirety of my security software.

Nothing on my machine has changed since it was working well over a month ago (well, now that the BitDefender suite is reinstalled). My router isn’t interfering (unless Battle.Net suddenly has new port requirements I’m completely unaware of?), and testing has proved nothing security-related has any effect…

You are extremely lucky to have never hit a snag in all that time, honestly. I’m rather envious. I have had numerous problems with WoW and the launcher over the years, but nothing as unshakable as this weird issue.

I just wish those in the know would offer more assistance - mostly because of close familiarity and access with the coding involved - instead of booting users out into the forums. Don’t get me wrong; people like you who put forth the effort and time to help are a great asset (and very much appreciated)… but when it comes to something that obviously requires in-house and / or proprietary knowledge to come to a solution, you MVPs can’t realistically be expected to fix what you wouldn’t have the tools needed to do so.

At any rate, despite this looking more and more like a situation that won’t be resolved (hope I’m wrong!), I’m still appreciative of your help.

Same exact issue here plus the Version 1909 error again! Odd that all works fine on my other machine which has an IDENTICAL SSD cloned O\S and naturally runs out of the same router. A few different HW specs but, nothing regarding the connection. just video and Cpu.