MW2 w/ preorder won’t allow me to play beta?

So I went through a whole process of preordering the beta today, probably due to high congestion but now it gave me the option to download the beta. Still gives me option to preorder even though in account transaction history and bank history it shows I’ve purchased. So I have the beta downloaded but it tells me I can’t play. I’m really confused, I’ve even logged out of battlenet and restarted my pc and no luck. Anyone else having issues?

8 Likes

I had it earlier and uninstalled and reinstalled it a few times now it loads but it says I cannot play it unless I add my phone number which I cannot do because they do not accept prepaid numbers so I paid for a game I can never play I guess unless I get a non-prepaid number. Maybe I should have ordered it on Steam.

2 Likes

I am Having the same issue over here too. let me know if you figure it out

yeah same I own Call of duty modern warfare and call of duty cold war and I pre-ordered MW2 and none of them work super pissed I should have just went through steam

close to my issue ill just send to my friend a gift of call of duty cod mw but after he claimed /recieved the gift it not appear anywhere in his account. and when he click on COD MW from the battle.net program it only gives the option to purchase the game with no obvious place to begin his download of the gifted game. Anyone else having issues? how you guys resolved this.

I am having the same issue. When I try to click play or hover over it, it says “This game cannot be played yet.”

Im having the same issue aswell. I preordered the game a month ago and its saying i can’t play the game yet. I’ve uninstalled and reinstalled the game almost a million times and nothing works. I can get the game to launch by right clicking the desktop shortcut > Open file location > beta > cod (296,079kb) But then it just gives me the error code BLZBNTBGS000003E9.

2 Likes

Hello all. I’ve been having issues where I cannot click the play button. It says this game cannot be played. I read on reddit to change your battle.net password. It worked for me. I closed BattleNet app on my pc down. Then went online to change my password. Then logged back into the BattleNet app with the new password and it worked. Please share.

I’m going to try this I’ll let you know

This does not work sadly for me. It’s bullsh1t and I’m pissed. I pre-order the game I expect to play The early access and here I am not able to play what’s promised

If you click where it says game version then it should say Beta mw2 so click that then click install. Hope that helped you.

first thing I did I am able to install the game but the play option is unavailable

i love that its been hours since the beta has been released now and this issue still isnt fixed. Mine says “this game cannot be played yet” and the play button doesnt work.
would be great to get on this sometime in the next few hours…

2 Likes

This did not work for me either, this is bull, its the open beta but i cant play, when i hover over the play button it just says “this game cannot be played yet”, this is pissin me off and its annoying

PC Open Beta: The rest of the weekend, from Saturday, September 24 at 10 AM PT to Monday, September 26 , is accessible to PC players regardless of pre-purchase status. The entire community can now experience the impressive amount of Beta content available in Modern Warfare II , unlock rewards available in-game at launch, and play together.”

https://news.blizzard.com/en-gb/blizzard/23837936/announcing-open-beta-times-for-modern-warfare-ii-and-the-call-of-duty-next-event

this worked for me! they should make it a little more visible to see, never would of guessed otherwise

Try loading the game through the file directory. Go to where you placed the download file, click the Call of Duty Launcher (fill out info), and restart the program via Battle PC App. See if that works for you.

Hey I figure it out. I did all the steps from resetting network, flushing cache, logging out, etc. The thing that worked for me was installing it on steam. Bottom line.

Oh, so their buggy launcher was routed out of the loop and suddenly it worked? HOW SURPRISING