MW2 Not showing up in BattleNet launcher/cannot preload Beta

I am having trouble updating the client this morning. I’ve tried to run as admin and repair the client.

I am recieving error:

We need your permission to continue. Try again and when the Blizzard dsektop app or Agent asks for permission, please grant it. Code: BLZBNTAGT00000870


am getting the same exact error at the moment. have never seen this error before. also tried running as administrator and no luck. i don’t get a popup from my OS asking me to approve any permissions

thanks, this worked for me

I’m having the same issue, I’ve tried reinstalling, I’ve got no launcher updates and I’ve opened both and launcher in admin mode and still no beta appearing anywhere.

I’m based in the UK and it’s set to Europe region.

I’ve dropped down the menu and all it shows is call of duty: modern warfare II.

It shows I have purchased the game, I bought it in July.

The only option at the top says “shop call of duty”

I’ve searched through my emails and have no code to redeem.

It’s really frustrating as I’m away from tomorrow so was hoping to at least get one evening of play time.

i have the exact same problem , i have the game but no beta appearing in my . it is really frustrating

1 Like

Same damn issue. Redeemed early access beta code on battlenet website but no download option on battlenet desktop app.

Apparently the beta starts at 1PM ET

same here in RU region , ticket to support but they not speak clear to whats happening

1 Like

I also own the game, but I don’t see the MW2 icon. RU account :frowning: Help

You verfied your phone number on battle net website?

Yes security Checkup 100 percent
I’ll just add that I’ve had the game on my account for about 2 months, but I can’t see the icon until today :frowning:

i’m having the same issues; uninstalled/reinstalled, ran as admin, tried everything that i found worked for other people and still cannot install the beta. it just doesn’t appear in the dropdown. submitted a ticket hopefully they can resolve this fast…

As in it goes live or the install for digital battlenet goes live at 1pm ET?

I also am getting this error BLZBNTAG00000870

hey i pre purchased and installed the game and all but the play button is grayed out and cant start the game

You can play after 6pm uk time

This is annoying with it not showing up

Yes! Going through the task manager to end test on all was key! Then I opened it again as admin mode and it actually updated!

Thanks a mill!


mine has done the download but now where the option to press “play” is not highlighted and wont let me click it, just says you cannot be played yet, im uk . i downloaded this on my main pc earlier and the play button WAS highlighted then, went to play it 10 mins later to be asked to update it, then did the whole you cant update this bs. uninstalled it and tried to reinstall, that was 2 hours ago with a WIRED 350mbps internet connection and im on 5% downloading at 45 kb/s
came downstairs and tried to download it on my gaming laptop and its just downloaded in 3/4 minutes on wifi but now wont let me click the play button
WTH is going on. anyone else have this problem ??

1 Like

I had the same issue, opening task manager and ending all the processes including the “ Update Agent” process fixed it for me.