MW2 Not showing up in BattleNet launcher/cannot preload Beta

I prepurchased MW2 last night so that I could preload the Beta.

It is not showing up as one of my games in the BattleNet launcher so I am unable to preload the Beta. When I go to the MW2 page in the shop and attempt to repurchase it, it says I already own it. It even shows up in my recent transactions on my account and through my bank.

I submitted a ticket but all they said was to wait until the game actually releases to try installing it but as you probably know, the PC Beta begins on Thursday (09/22).

Any solutions?

18 Likes

hello , i have similar problem too . the game show up for me but the download option for the beta doesn’t (beta version) , weired , i just submitted a ticket after i tried everything . i did not find anything that helps in the internet , guess we are the only ones having this issue LOL .

7 Likes

Same here. Weird thing I can see the Steam page for it and if I actually pre-ordered there I assume there would be no problem.

yes really weired , first time having this kind of issue

1 Like

When you bring open MW2, right above the Install button there is a drop down that you have to select Modern Warfare II Beta. I can install, but then it requires an update and I am unable to do the update because it says I did not give permission to change settings even though I already have clicked Yes multiple times.

25 Likes

Hi:

The same issue has been reported on the French language Blizzard forum… this issue seems to affect several players.

Perhaps the final update will only be available later ???

4 Likes

nah bro, MW2 doesn’t even shows up in My Games despite me having the game.

I mean if I go to Store and select MW2 it says “you already own this game” but again, there’s no icon in My Games (and I don’t mean just “favorites” neither + nor do “owned games” tab show anything)

19 Likes

same happens to me i redeem a code today but still nothing is visible in my account what is going i can preload the game beta start tomorrow

1 Like

I was having the same issues but the link was right on that tab under the MW logo. It was written: New Beta available. So I clicked on it and then it worked.

hello the option
"in development
modern warfare II beta "
is non existant for me , there is no such option for me , tried what u said exactly and everything else that i could do still no solution

My mistake sorry… the option should be available if you click on the drop-down box… I’ll re-do the screenshot and post it in a few minutes.

1 Like

no problem , i know already , no need for a screenshot

same
mw2 isnt showing up on my main acc (ive tried reinstalling battle net even after removing all its files too )
the game is showing up on my new acc which i just created
Note: My main acc region is Russian Federation so maybe thats why idk

I am having the same issue as above. The game is not showing in my library even though it says i own it on the store page. I have opened a support ticket and all they did was tell me to contact activision and said my “code” would work tomorrow. There is no code for battle.net pre orders as far as i know. Support worker was so happy to just copy and paste 2 links and send me on my way. I dont even know if it was a real person at this point

1 Like

Hi,

Click the + sign on the “All Games” bar to add a favorite.

 

Select “Call of Duty: Modern Warfare II”

 

This will add the MWII icon on the All Games bar… and display the CoD: MW2 info. Click on “New Beta Available”.

 

Your Battle.Net Desktop App should now look like this… and show “Modern Warfare II Beta” and an “Install” button. Mine is showing a “Pre-Purchase Now” link because I haven’t bought MW II.

I hope this helps a bit.

6 Likes

I do not even have the option to add it to favorites. It is not listed in My Games, it is not an option in Favorites, but it shows I own in when trying to prepurchase it…

8 Likes

nothing on my new tab i already redeem code 12 hours back which activison sent me

1 Like

Hey guys update i have completely reinstalled the battle.net app and its now showing in my library. I wasnt able to uninstall it until i did another install if that makes sense. Once i had properly uninstalled and re installed battle.net it was showing in my library. I think my app broke during an update as the app is different with a fresh install. Hope this fixes it for you guys too

5 Likes

thank you but as i told you , i already did these exact steps over and over but the is no " modern warfare II beta " in my game version , it doesn’t show up , i tried so many things still can’t find it . i submitted a ticket and still waiting for response . this is so weired , i think if it persists i can’t even play the open beta , sad /

A fresh uninstall and reinstall of the battle.net launcher fixed it for me! best of luck friends