MW2 Beta : We need your permission to con tinue

I installed the beta yesterday, today (09/22 0546p est) when attempting to update the beta, it comes up with a box saying “we need your permission to continue. Try again when the battle.net desktop app or battle.net update agent ask for permission, then try again.”

It is not giving me any prompts to grant permission, however.

(windows 11 PC)

6 Likes

i have the same issue. WIN10

I have this issue too, Win10. Tried running as administrator, nothing

Attempted to uninstall and reinstall, luckily I have fast internet lol.

It seems to have fixed it so you might have to try that

5 Likes

I may have figured something out; I hit update and before it had time to do that popup, I accidentally hit pause so then I resumed it and it immediately changed to “Play”

33 Likes

I am having the same issue. I even reinstalled and no luck.

This worked for me as well. Thanks!

1 Like

I got it to work by restarting my pc.

3 Likes

Happens to me aswell. Tried reinstalling it. Tried starting both the beta and the battle.net as admin, does not work. tried the method StayFrostyB is doing, does not work.

It’s wierd how the update requires my permission. But is not asking for it. " When the battle.net desktopp app or battle.net update agent asks for permission, please grant it." Well i would love 2 if you just showed up and asked for it :stuck_out_tongue:

1 Like

Just restart your system

1 Like

worked for me also, thx !

1 Like

I did the below and it worked for me.

Windows

  1. Right-click the Battle.net desktop application icon and select Properties.
  2. Select the Compatibility tab.
  3. Click Change settings for all users.
  4. Under Privilege Level, check Run this program as administrator.
  5. Click Apply.
4 Likes

HAHA this worked thank you sm brother!

1 Like

work, tank you bro!!

1 Like

i found a way to fix it. you have to press modify install, select any language download it, and the game should open after

1 Like

i got the issue to WIN 10

does work, thanks man!

youre an American hero!!