Multiple games losing sound during play; closing randomly

For the past 2-3 months my games (SC2, HOTS) will intermittently lose sound while playing and close without showing any error message. This is not the case with games on other platforms.

I’ve checked dxdiag, ensured all my drivers are up to date, deleted my game caches, and tried running them without my antivirus. Nothing has worked so far.

Can you elaborate on this? Did you export the report and check the errors listed at the bottom, or only run the tool in Windows? It definitely seems like the sound drivers are crashing intermittently.

There are some errors but I don’t think any are audio related.

pastebin dotcom slash NDU82QBJ

I recommend clearing some space on your drive, you need 15–20% free for an SSD to work properly.

Drive: C:
Free Space: 52.3 GB
Total Space: 476.3 GB
File System: NTFS
Model: Samsung SSD 850 EVO 500GB

After that, run a repair on Windows; looks like some system files may be corrupt or missing per the report.

1 Like

Did the Windows DISM/SFC process. It said it repaired some errors but it didn’t change the dxdiag report much, and hasn’t allowed any Blizzard game to run for more than 30 seconds at a time.

pastebin dotcom slash s1bAVS2

As for the SSD, this was happening before the drive got so full. I will try to clear up space but I don’t believe this is contributing. I also did a CHKDSK to confirm the health of my drive and found no problems there.

Again, this only happens with Blizzard games. I can run games on other platforms that have higher system requirements with no issues.

I appreciate the continued responses.

The report will only change entirely if you delete the Windows error logs before experiencing the issue and collecting a new report.

That utility is checking for errors reading the boot record and defrag status, but has nothing to do with whether there is enough space for the page file. That’s the reason to keep open space.

It expired, so I can’t review it.

1 Like

Sorry - not sure why it expired. I opened up some drive space today, cleared my Windows error log and performed another dxdiag.

pastebin. com/3Yf3w7Ce

I also saw an actual error today when trying to open a game. “An error occurred starting Heroes of the Storm. Please try again. (Error 2:0).” Still no luck running any Blizzard game for more than a few seconds.

Event Name: WindowsServicingFailureInfo
Response: Not available
Cab Id: 0

Problem signature:
P1: 10.0.19041.3684:1
P2: 0x800F0984 0x800F0984 Matching binary: wvkrnlintvsp.inf missing for component: amd64_dual_wvkrnlintvsp.inf_31bf3856ad364e35_10.0.19041.3636_none_7e5fd8b3e3b57420

I was trying to look into this error, which I believe is related to your bios, but only came up with a few suggestions about SVM mode. I also see there is a a network tool error. According to Microsoft, it only throws errors when system files are corrupted.

Blizzard staff may have some clues if you open a ticket with them, but I personally recommend starting a thread in the Microsoft community. There are a lot of PC techs in there and they can read your error log dump files (not the ones we’ve discussed so far) for more info.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.