Multiple Agent processes eating up system memory

Hey, after the big launcher update I’ve had this issue where launching WoW will spawn multiple Agent processes that proceed to slowly eat up more and more memory on my system until I force kill them. The issue is then “solved” until I launch WoW again, where several Agents are spawned and start dutifully consuming memory once more.

Exiting WoW does not terminate the Agent processes, nor does exiting the launcher. They seem to be zombie processes. I can attach a sample from one of the Agent processes, if that helps.

(Cross-posted from the World of Warcraft Mac Support forum, I think this is probably a better place to post this.)

I posted about this issue as a bug in the. bug report section. It probably is a Mac-specific bug. Are you on a M1 or M2 Mac like me?

1 Like

Same. Each agent PID takes 100% CPU on my M2.

1 Like

Glad to hear it isn’t just me. I’m on an M1 Mac as well.

Same issue here. I first noticed it yesterday.

1 Like

Same issue here. I had three games that needed an update:

  • Warcraft 3 Reforged
  • WoW Retail
  • Wow Wrath Classic

Upon launching, my computer would spin up literally 12 Agent processes and just kill the system. I changed Automatic Updates to “Never automatically apply changes” and I was able to launch Battle.Net and nothing spawned.

I manually updated Warcraft 3 Reforged and it launched a single Agent and worked just fine. I tried to manually update both WoW Retail and WoW Wrath and had the following experience:

  • The UI changed to “Updating” and an Agent process spawned.
  • I watched the UI kind of flicker from Updating to Update to Updating again, and it spawned a total of three Agent processes
  • I got an BLZBNTAGT0000138F error
  • I had to manually kill the processes

I can’t test again because of no other games needing patched, but considering WC3 updated, I think something is messed up in the Updating process of World of Warcraft

EDIT: This happens on two Macs I own, one is Venura and one is Monterey

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.