Modern Warfare 3 Not Installing

Whenever I attempt to access Modern Warfare 3 modes within Call of Duty HQ I receive an error that DLC packs are missing and I am prompted to install the files through Manage Content. When I follow these instructions it shows MW3 is already installed. I do not see an option to manage specifically MW3 campaign or multiplayer as other instructions have shown.


This text will be hidden


Same, does anyone know what the fix is for this issue? I’ve scanned and repaired and uninstalled and reinstalled the game multiple times. I’m about to refund it

same for me bro it sucks

Also same, would love a fix

May have found the fix… Next to “play” go to options.

  • Click on “beta” on the left hand side.
  • Switch to the beta version of Battlenet

This should bring the missing update to the game.

Let me know if it works for you guys…


“there arent any betas to test right now”
did you try this option or just guessing

Its not a Call of Duty beta, it’s the app beta. Next to play its Options > Game Settings and in Settings you should see a Beta section. I’m testing it right now.


still the same message, did it work for you?

After switching app to Beta I was able to download an update for Call of Duty and can now access the MW3 content

1 Like

can confirm this worked for me! Thank you for the resolution that was infuriating.

1 Like

If the Beta isn’t there re download app on your PC. Can confirm it Just worked for me!

Uninstalled battlenet and reinstalled and now have a 100GB update after fresh install of MW3 and getting the DLC message when trying to play any game mode. Hopefully this is the fix.

Why does it take days to donwload mw3? the download speed is atrocious

This fixed my issue!

This “Fix” is not working

Worked for me too!!! Thanks for posting

Wow! Thanks so much for this, but why in the hell would they do this?!!! So freaking ridiculous. I would like to be compensated for the last month i could not play and all of the time I spent trying! So angry!

BROOO, WTF took forever to find!!! It worked so CLUTCH.

BTW everyone, go to top left where Blizzard icon is, drop down then go to setting and beta and you will find it.

Blizzard no wonder you got sold to microsoft!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.