[Main Thread] Can't launch the Battle.net App - DLL error

This could be a way out… if everyone was impacted by this issue.

Which is not the case.

I think it is best if they try to figure out why it didn’t work on the few instead.

Yesterday, i did a reinstall and it worked after that but today… i tried 4 times and still it doesnt work…

1 Like

I am still having the same issue Blizzard please fix your DLL with a new update stop telling us reinstall stop being lazy and fix it

3 Likes

Also broken here.

Windows 10 x64 Home
Version 21H2 (OS Build 19044.1586)

I’ve run the bnet installer (without uninstalling beforehand) and that’s let me login again, but I’m avoiding restarting my PC until a fix is confirmed.

I deleted the 13360 folder without reinstalling B_net, and it launches fine.

5 Likes

Hi,

Two players on Europe French forum say that they deleted the Battle.Net.13360 folder and that everything is now working. See here and here.

I hope this helps.

2 Likes

Hey again everyone,

Just got word that the cause of this should be addressed. It does seem that it may not be a retroactive fix in that if there is bad files are remaining, they will need to be manually deleted. The idea is what was shared earlier.

Using file explorer, go to where the Battle.net application is installed. Typically thats: C:\Program Files (x86)\Battle.net

Look for any Battle.net.##### folders here. The ##### is probably going to be 13360 in this case. Just delete those folders and then restart the Battle.net application. A reinstall should not be needed.

I’ll keep this thread open for now to monitor if this persists for anyone. Thanks Boubou and everyone else for the updates and patience while this was sorted out.

6 Likes

Had the 13360 folder in my install location, deleted it and bnet launches fine now, including after a system restart.

3 Likes

Thats what is happening to me i tried everything

2 Likes

Did you remove the 13360 folder? Fixed it for me without having to reinstall.

1 Like

So uninstalling and also deleting folder fully to start off fresh with a reinstall… When doing this went in to install it… It works fine, But when exiting out of the blizzard app the dll file error still shows up…

1 Like

I had a 13360 and a 13365 folder there. When I deleted both and restarted Bnet I got the DLL error. Putting back the 13365 seems to work. Worth noting I ran the installer with Bnet installed to fix this before so maybe thats why there were 2 folders for me. Bnet is normal atm for me…

I had the same problem. DLL error. I tried to uninstall the launcher. But when I tried reinstalling it, the process is completely stuck on 1%. I tried several times by just deleting all the files that were installed with the uncompleted installation, but nothing seem to work.

Same issue here, mine is stuck at 1% even after going through all the steps

Same here

Deleting 13360 and 13365 worked

1 Like

Ive done all the above, deleted the files. reinstalled the launcher. Trying to avoid needing to reinstall everything. Still getting the error BLZBNTAGT00000BB8 - Blizzard Support and the game prompts to run the repair which takes 20 minutes then fails once it gets to 100.

Was getting this. Deleting the folders didn’t work for me, nor did a repair. I had to completely uninstall and reinstall.

2 Likes

youre kidding… SO youll have to reset all keybinds etc :((((

This one was solved by moving to mobile data - so likely there is an issue on the modem which I can deal with later

So far this is what I did on my boyfriends computer: I deleted the 13360 and 13365 folders, there was also a temp file that I deleted. Uninstalled the software. In control panel I went to the windows features and I turned on SMB 1.0 protocols on, delayed the restart. I installed the battle.net software open the program then did a restart. After the restart the battle.net app opened without the .dll error message.