Mac - BLZBNTBTS00000029

It will not even let me install the Battlenet app.

I have done all the suggested self help fixes. No go.

Any ideas?
macOS Big Sur v 11.2.3
iMac i5 3.4 GHz
16 GB Ram

5 Likes

Howdy Thumperness,

This typically indicates something on the computer or network is blocking the connection to the patch servers. Did you try disabling the firewall temporarily?

If so, please reply with a full list of steps so we can get this further investigated.

I also am having this issue and have tried. everything. firewall currently turned off. I keep trying to start a ticket and am getting very frustrated. It has been over a week.

3 Likes

Howdy FrostyFeet,

Does the problem persist on an alternative connection or VPN? If it persists, these steps may help with the issue.

I’m having the exact same issue on my Mac OS Big Sur 11.2.3.
Uninstalled early this morning due to Retail WoW not updating properly. At this point classic WoW was still running. Deleted the battle net app and all WoW files. Reinstalled only to find the BLZBNTBTS00000029 error code.

I’ve tried restarting the computer multiple times and deleting and re-downloading the battle net launcher without success. I also tried downloading World of Warcraft separately which showed the same error. Filevault and Firewall are disabled. All background applications are shut besides the battle net installer. The link for alternate download is for windows, thus it does not work. Checking the host file is also for windows, so does not apply. Testing another computer is not an option. Tried creating another admin account and this did not work either. Frustrated as well as I just bought 3 months of gametime before everything stopped working. Not eager to have it waste away as looking back in threads of this same issue happening with other Mac users, the problem was never resolved.

4 Likes

Same Problem here with my imac Big Sur 11.2.3.

Any updates to fix this? None of that worked, im also on Mac Big Sur

Same issue with Big Sur 11.3

lol I guess I never tried this but it did allow me to redownload the app. Disabling Proxy Settings - Blizzard Support (battle.net)

1 Like

Its baffling that EpicGames gets this right, where Blizzard can’t. Sign of the times??

I am having the exact same issue. Filevault and Firewall are off. I reinstalled the Battle.Net App and Wow and I still have the same issue. This is not resolved.

Also having the same issue. I’ve tried all the suggestions so far and nothing to show for it. Need a proper fix right away blizzard!

yep I’m having the exact same problem!

the alt download link is for windows when this is a Mac specific problem, why am I not surprised

So no answer to this yet??

Pretty upset, been dealing with this for months now on and off.

Having said that, Disable the proxies seems to have worked for me. See link above:

2 Likes

This worked for me!! Thanks for the suggestion I was losing hope haha

Hello. It works… Great !!! Thank you.

So I’m running MacOS version 11.5.1 and just tried to download Heros of the Storm setup and the Battle-net-setup app.

And this gives the following message: " You do not have permission to open the application “Battle.net-Setup.app”."

Checking the permissions, my account has “Read & Write” access.

On a lark, I changed the permissions for “everyone” to “read and write” as well, and this fixed it.

Not at all sure why I needed to change “everyone” on this file, but there is your answer. At least for my system.

OK thanks. It seems like this was the problem for me as well.