Logitech gamepad F310 troubles

Playing Diablo Immortals on PC Beta (latest version as of June 6 2022) Using Controller for gameplay / button config troubles.

I use an Xbox / PS4 style joystick controller for my PC games. Logitech gamepad F310 . It shows up and works very good in game. All but two buttons work. The LT and RT buttons do not work in game. Nor are they detected when configuring the controller settings. The Logitech F310 controller has a couple buttons, one on bottom side of the controller, not sure what it does, but I use a button on the top of the controller (Mode button) to switch from Joystick controls to Directional pad controls. I prefer and use the directional pad, so I am not getting any movement issues, lag or otherwise using the D pad on the controller, like others are reporting having with the Joystick controllers. using Dpad mode I am not even sure what the joystick controls even map to ? Ill have to check.

Other than that, the game would work flawlessly with only a controller on the PC version, if those buttons worked that is. I could possibly remap those RT / LT skill functions to other buttons, but then I lose those already mapped functions. Hopefully just a BETA thing.

Mr B

1 Like

I am getting this same issue. I went through windows controller set up and the buttons show they are working fine.


1 Like

I have the same issue with a Play Station type controller. Logitech gamepad F310, Left trigger and Right trigger don’t respond, It does work on my phone a Samsung Note 10+, but not on my pc.

1 Like

My Logitech F310 was working flawlessly all weekend, but sometime within the last couple days it has started malfunctioning to the point where I cannot use it reliably. If I press the B button to fire ( I am playing a Demon Hunter), it will fire once or twice and stop. Movement is similar. It will move a short distance and stop. Today I noticed that when it stops responding, the GUI shows the keyboard controls are active instead of the controller buttons.

I tested the controller in another game, the other game plays flawlessly.

Was a patch to the game released within the last couple days that might have impeded the functionality of the device?

UPDATE: I saw another post that talked about changing the display from Fullscreen to windowed. That made my experience better, but I didn’t like the appearance. I tried going back to fullscreen and the controller was still working. Try switching between display modes. It may help.

SECOND UPDATE: I signed into the game a couple hours later, and the intermittent behavior is back. I have not yet found the cause or reason.

THIRD UPDATE: This morning the controller worked flawlessly again for a couple hours. I stopped for lunch, and when I came back, my controller was not working normally again.

1 Like