Launched Problem

Launched app,HIT PLAY and nothing HAPPENS just minimizes the app and nothing few moments LATER tells me to hit play again
PLEASE CAN ANYONE HELP ME
MY SYSTEM IS MORE THEN Required Capability
:pray:t2: :pray:t2: :pray:t2: please help me :pray:t2: :pray:t2: :pray:t2:

I had the same issue the only programs I could not run were Blizzard Battlenet app. and consequently all of my blizzard games. I would launch the app it would appear in tray and nothing. Tried re-installing app several times and it worked once but then same thing. and had to resolve on my own after following all of the β€œBlizzard suggested troubleshooting.”
So while running the MSinfo and DX Diag to send to Blizzard tech support, I was browsing through MSinfo and found that AudioDG.exe was causing errors every so often . The solution for me was to update my audio software for my wireless headphones. Steel SeriesEngine 3. As soon as I updated the software and did a shutdown restart, Boom! Like there was never a problem. Hope this helps.