Latest Battle.net BETA update stopped working correctly on Linux

I’m using Linux with lutris (always trying various wine versions). After restarting BattleNET beta (client informed me there’s an update) BattleNET is showing white screen - tooltips and notifications menu work fine, so it seems app is running ok, just everything on main window is white.

After reverting back to retail version the issue is gone.

10/10 UPDATE: The “change” has been propagated to retail client as well and battle.net does not work for me correctly anymore on linux.

4 Likes

same problem, updated the client and now i get a white screen

at first the app wasn’t working at all and crashed right away, but after updating wine to lutris 4.16 i have a white screen

the buttons for starting a game are working even when i can’t see them, clicking blind on them is working
so i guess it’s just a rendering problem of the app itself

please, even when you don’t officially support linux, fix this

thanks in advance

Same thing happening with mine.
Wine 4.16, NVIDIA 435.21, DXVK 1.2.2, Debian Sid

Do this: Add the two libraries referenced in the following link, should clear the white screen issue. Worked for me, but YMMV: https://eu.forums.blizzard.com/en/wow/t/battle-net-launcher/94401/8

I did add the libraries. Somehow while I’m able to get to Starcraft running, I can play a vs an AI abut when I try to load an Arcade I can’t get it to run. It start the loading screen reaches 4/5 of the way and it just stops working. I tried both install script from lutris but its a no go! I with one script I get an e_gfxErrorShaderCompileFailed error while with the other I get a freeze. I have no idea whats going on!

Yeah same with me, and it doesn’t even let you reinstall it either.

Same problem, please fix.

Same problem. Just paid for 6 months of sub and dragonflight so I’m quite frustrated. Please fix.