Last update completely breaks wine compatibility

No problem, sadly I’m not sure it will actually help. I’ve been unable to make it work, bnet seems to be replacing it regularly. Others have said it helped them though so who knows

1 Like

Yeah, not having great success either, not sure what kind of stuff they did to make it work.
Hotswapping it in while bnet is running doesn’t seem to work, it continuously overwrites itself with the new one, and revoking permissions to edit the file to stop it from changing just ends up with bnet hanging.

1 Like

Just chiming in to say I’m having the same issue. I know linux isn’t officially supported but it has worked pretty well until today, and I prefer not to use a telemetry-ridden OS!

1 Like

Same issue here on Arch. Wish I would have searched first because I thought the update failing could be fixed by uninstalling and reinstalling through Lutris.

I was able to play by getting the client up, playing overwatch and immediately closing the client. I also kill all .exe processes before starting this process with the following:

ps -ef | grep \.exe | grep -v grep | awk ‘{print $2}’ | xargs -r kill -9

1 Like

Just throwing my hat in that says getting this fixed is important to me.


Same here, this game ran flawlessly for at least a year. I also was able to play D3, HoTS, Starcraft II, and Diablo Immortal without ANY issues at all. Install of the newest hangs at 50% and reinstall is impossible due to this same hang-up.


I’ve been playing WoW (retail and classic) for over 2 years on Linux. Very few issues until yesterday when stopped working in wine.

Please Blizzard give us Linux users some love and fix to work in wine again.


Please fix this blizz. I got my steam deck just so I can play wow wrath on the couch with wife and baby, but literally, overnight it broke.


Wine bug report and workaround:

Go to Wine website, click “Bugzilla” and search for 53697 in the LEFT search box.
(not the upper right search box)

I’m not allowed to paste links here…


The issue with replacing the Agent.exe file stems from it being overwritten on a regular basis. I have installed fresh in Bottles and Lutris using the Overwatch script (the setup file from Lutris used in Bottles) and if you do not add the --exec=“launch D3” or Pro (ie a game you do not have installed), will replace the copied file immediately on launch. IE if you do not use the launch option, instant replace, if you do use the launch option but have the game installed, instant replace. As suggested on WineHQ, you can change the permissions to stop the file being overwritten: sudo chattr +i /path/to/Agent.8009/
Hopefully someone will be able to identify which dll is missing or mismatched to fix this.

Wow working again, thanks.

This is def game breaking. Many people are reporting to unsub until the issue is resolve; and I don’t blame them.

I play original WotLK via Wine 15 years ago and never had this issue. This is pretty sad…

1 Like

Same issue here - just adding a post so there’s more visibility over the user base affected

1 Like

Hey blizz, having the same issue. I play on my steam deck and it worked FLAWLESSLY before the last update. I know its not officially supported but any help would be great <3

1 Like

I was quite enjoying playing Star Craft Remastered on steam deck. Was considering buying the cartoon DLC for it. I’ve now run into this same issue. +1 affected linux/wine user.


Same here, was getting stuck on setup.exe on steam deck.

Its definitely not. I have even tried to use the wine bugzilla workaround, but no luck there either…

You can access the wow.exe client directly as a workaround for now, but if they update it, then we are boned :smiling_face_with_tear:


Same issue as everyone else. Please fix.

Same issue as well. Please provide support.

Same. On Arch Linux, with latest wine-staging. Install BNET now hangs indefinitely, it didn’t used to.