Last update completely breaks wine compatibility

Adding to this as another member of the Linux crew. I’d love to be able to play OW2 on Linux just as well as OW used to play.

1 Like

I have 3 Linux computers that cannot play any of our blizzard games (SC2, D2R, and HS at the moment). I would like to add to the request to get this fixed please.

The work-around from reddit fixed the issue for me. It would be great if Blizz supported Linux.

P.S. - I’ve run into a new issue with the PTR (Dragonflight-PrePatch)[Worried we won’t be playing DF on Linux]. I was playing on the PTR when the servers shut down earlier today. Battle.net downloaded an update(for the PTR). Now I am unable to open the game because it’s telling me I have an unsupported 3d accelerator. GPU is Radeon RX 5700 XT MECH OC. It’s more than capable of running WoW. I’m still able to play retail, wotlk beta, and classic wotlk pre patch just fine. Its only happening with the PTR client.

For whatever reason the ptr only runs when I start it with -d3d11legacy.

I put

-d3d11legacy

In Game options > Arguments and am getting the same unsupported 3d accelerator error :frowning:

Try launching the wow binary directly with wine (/path/to/wow/_ptr_/WowT.exe -d3d11legacy)

That didn’t work either. I’m trying to install DLL with winetricks and messing around with overrides there. Not having any success.

Also tried running on AMDVLK/AMDGPU PRO instead of MESA:RADV. Nothing is making PTR work. :frowning:

Crazy thing is that PTR was working perfectly earlier today.

I have the same issue with retail when i use proton experimental, maybe try another version of wine/proton.

What I’ve found is that it’s best to hit the play button and then close BNET.

I’ve been able to play daily on EndeavourOS (Arch), but since the update, if I leave BNET open for like 60 seconds, it will start throwing an error message here and there. I can’t make a desktop shortcut either, so I just did it manually.

My .desktop file looks like this:
Exec=env WINEPREFIX="/home/mark/Games/World of Warcraft" gamemoderun wine "C:\Program Files (x86)\World of Warcraft\World of Warcraft Launcher.exe"

So long as I click this, and then when the launcher loads, and I immediately hit “Play”. It’s no problem.

I also have BNET set to exit when the “X” is pressed, and to also exit when a game is launched.

I chose the day everything broke to start trying to add WoW to my Steam Deck lol

Tried everything here and then some. Fixes where you have to log in every time aren’t all that appealing to me but I did get that working by copying my PC’s install over in warpinator.

Nothing I’ve tried gets the games out of the bnet update loop

Now lutris won’t even do a fresh install of battle.net, just getting stuck on the agent updating at 50% again so I’m all done with trying. Sticking with PC until whoever broke it fixes it.

3 Likes

I had some issues the other day regarding teh agent.exe file and was able to fixed it by replacing it with the old version and reinstalling wow using the overwatch script for battlenet.
I have been getting bnet errors for a couple of days now and bnet just freezes and I am unable to play.

Its got an update loop now

Just to point out, there’s a thread on the forum also saying some Windows users have had difficulties after the most recent Agent updates too. So, I do think it’s more an Agent bug that just triggers far more reliably in Wine than something that was intentionally put in to break Wine (… or more likely to break Steam Deck)… and even if it was put in with that intent, if it’s hosing some people’s use in Windows too it’ll have to be fixed or reverted anyway.

Good hunting tracking and fixing this bug!
–Henry

Yesterday managed to play Hearthstone a little with help of Windows10 VM (virtualbox).
By copying the “Hearthstone” folder entirely from Windows-VM Program Files there to my wine Programs Files.

Today however, it again doesn’t start anymore in Linux, but tries to force some “update” for some reason. Although in windows VM it didn’t need to update, nor did and started fine. Anyway, copied the folder to Linux once again, and still nothing. On linux side it still wants to “update” something. Is there something else I need to copy over from windows side besides the game folder under “Program Files”?

Using Wine Staging 7.17 on Arch.

I get very slow download speeds - like 2MB/s. Loading times for WoW have also significantly increased.

So I went on Windows, and it was exactly the same thing.

I’m truly not convinced this is a bug in Wine, though of course it might be. Either way, I hope Blizzard looks into it.

There seems to be no effort to actually block Linux users. If that is what they wanted to do that is very easy - there’s literally a registry key giving the secret away instantly, and trying to make direct kernel calls is also likely to end in tears.

1 Like

I don’t know how you guys are playing wow on the deck, can’t bear it with a controller and its the last thing I would play on my Deck. Still unable to make any progress on my Arch PC :frowning:

Hello, I had success yesterday. But it’s not pretty.

  1. Use LXD to spin up a windows 10 VM (there are official canonical tutorials on this)
  2. Give the VM a beefier root disk
  3. Install Battle.net, set games location in another folder (I used: C:\Games)
  4. Rght click on Games folder, share with everyone (read)
  5. Download WoW inside VM
  6. After its finished, mount the sambashare using cifs type
  7. Rsync the files from that mount wherever you have wow installed on the host
  8. Unmount and close VM
  9. Play the game on the host

I suggest that the mount/rsync steps to put them inside a script since I even had to do this this morning for a small 50Mb update.

Remember, for every update, you will need to spin up the vm, open up battle net again, wait for the update and then do the rsync/mount thing.

1 Like

Great Post, let blizz know we linux users do exist.

1 Like

None of the workarounds work for me. With the hardwareaccel + streamingenabled tweak, I can get bnet to launch, install wow, and update it, but it crashes after a few minutes. It has downloaded the game enough that I can start it, but it crashes after a few minutes along with bnet.
We don’t want to play on Linux. We think we do, but we don’t.

We don’t want to play on Linux. We think we do, but we don’t.

They never said they support Linux, you can’t really expect them to support it. We as consumers took the risk. However, help would be really nice if possible

1 Like

22-09-22 workaround (based on bugs.winehq.org/show_bug.cgi?id=53697#c40)

  1. Download that Agent.exe in another comment (cdn.discordapp.com/attachments/538903130704838656/1020763521631404103/Agent_7984.zip)
  2. Replace $WINEPREFIX/drive_c/ProgramData/Battle.net/Agent/Agent.8012/Agent.exe with Agent.exe from the zip file.
  3. sudo chattr +i $WINEPREFIX/drive_c/ProgramData/Battle.net/Agent/Agent.8012/Agent.exe
  4. start bnet and pray to whatever deity you believe (or not?) in.

$WINEPREFIX is well, your wineprefix, for example if you use bottles and you named your bottle bnet, it would be $HOME/.local/share/bottles/bottles/bnet.

Sometimes it will get stuck on loading all together, that happens on windows too (at least for me) so that’s a whole different bug.

1 Like