I can not reninstall Blizzard.Net launcher

So a few days ago I was having issues downloading the newest Destiny 2 update. Simply put anything I tried to fix the issue with did not work. So I resorted to just reinstalling the application. Once I did I would launch the Battle.net-Setup and at first, it would get stuck at “Downloading new updates” but I resorted to tricks such as going into all the files (localAppData, temp, Program data, etc.) and deleting any Blizzard/Battle.net apps. I even deleted all of my game downloads and their corresponding folders. I disabled Windows firewall and my anti-virus software and ran it in Admin mode. I could get the app to get to the installation phase. However, it gets stuck at 7% or 43% installed. I have noticed in my research that perhaps there might be a correlation to a weak internet connection, which I have been experiencing all week, but this is the only software that downloads anything that I’m having issues with. I read through Goose306’s post and I have done everything he has done except for his last 4 steps. Kaldraydis suggested in his post that he try downloading it from a hotspot from his phone. My desktop does not have a wifi adapter, but I tried it on my laptop on the same connection and it worked succesfully. I also did similar steps of uninstalling it on my laptop and reinstalling it and it worked succesfully. Any help would be greatly appreciated as this is an extremly frustrating issue.

Edit: I also tried downloading Destiny 2 on my laptop on the same connection and it worked. I was not sure if this information is important or not.

Hey, Jakefire209!

This does sound like a possible adapter related issue. Are you able to try a wired Ethernet connection to see if it helps? We will likely need to see your system files if that does not helps. Feel free to make a ticket at: https://support.blizzard.com/ and we can dig into this deeper for you.

I do not have a wifi adapter. I am have been using a wired Ethernet connection the whole time. I will make a ticket

Hey there,

One solution would be to transfer the files from the laptop to the other computer. Though that would require either a rather large external storage or to transfer it over the network. Both solutions are technically unsupported though so our ability to assist with them is rather limited.

If it’s only happening on one device on a single network, this typically suggests that the problem is either related to system permissions or security software. For that I typically recommend the following:

  1. Update the operating system.
  2. Try a new admin account to rule out profile corruption.
  3. Try temporarily uninstalling security software.

Well, this might ahppen due to the third party program you are encountering the issue.

So check the third party programs that runs in the background fom task manager and disable them. Also Grant Administrator Access.

Can you log onto another network? If you can, this worked for me to download the launcher. But I still can’t log into Blizzard.

I also Am having the same Issue, I have a cable modem that splits off to both P.C’s and all of a sudden neither of us can log into battle.net, i did some troubleshooting, then deleted, cleaned residue files and cashes and attempted to re-download, that was 12 days ago, I have reinstalled windows twice done all the looking glass stuff ran everything and it all looks good,(low latency) i’ve followed everything… the CMD prompts < i’ve run as Admin, deleted, redeleted when i go to install battlenet it just says “downloading new files” I’ve been so frustrated i left it for 4 days and came back still downloading those files !! tonight i tried downloading battlenet on my laptop and loading through a usb stick … No luck there , toggled security on and off Why/How? can 2 pc’s with the same fast internet go down at the same time and not be able to download battle.net?? i can play steam or g.o.g download youtube easily , at this point, i just dont know what to do.

1 Like

Oddly enough i unplugged the Ethernet cable and game works perfectly on Wi-Fi, this is not Ideal, everything else on pc works fast on ethernet not sure where to go from here, reset router added ports , flushed dns and everything known to me… Soo much fun.

Hey Shor,

do you have access to your isp firewall settings? If you can turn it off there for a sec and try the launcher it will work and then you should be able to go hardwire. Hope this helps, this just worked for me.

I have done everything under the sun, followed everything blizz has recommended to no avail and same as Shor nothing is working. Maybe its blizzes new way of kicking you out the door.

Hey Raven,

I’m not from Bliz but try this. Do you have access to your local ISP firewall? If you do, turn off or lower the firewall setting and it should be able to work.

I did everything like you but did not think of the ISP firewall until the very end and shazam…you’re back in baby.

done all that… it is on their end. I have 3 yrs of computer sciences and also A+… i done everything including the firewall… hell I tried 4 routers that i have. Still nothing.

I coudn’t connect lately to battle net or D3. So I deleted everything blizzard-related from my computer, and tried to install the program again, but it was stuck on “downloading new files” with the progress bar on a few precent all the time.

Tried pretty much every “solution” from blizz and people posts (including deleting every blizzard and BN folder and file from “appdata” and “programdata”, also did the thing with cmd and IP), which none of worked. I was ready to give up on blizz forever but as a last resort I went to my router’s settings, then security>firewall and changed the setting from “medium” to “low”, then started the BN installer again and it worked. I think I changed this option few weeks ago, and that’s why I couldn’t connect to blizz server (I didn’t launch BN since changing this option, just until few days ago so I was unaware that changing it interfered with BN) so here’s my solution.

My router is from Telstra and the options are accessed by going to http:// mygateway and loging in.

If you’re not sure how to access your router’s options, check the user manual or if you don’t have it, go to manufacturer’s website and I guess it sould be there. And even if you don’t know the login and the password, I think resetting the router to factory settings (there sould be a reset button on the device) should also reset the password.

Hey Raven,

I mean your ISP firewall, not the windows firewall. For some reason mine was set at the highest lvl and when I changed it to custom, everything started to work perfectly. I access my ISP through a browser and type in and that opens up my ISP providers setting page where I can change the firewall settings. Hope this works buddy, drove me crazy for 2 weeks.