How to open 2 instances of bnet for 2 separate accounts

Current: macOS Monterey 12.0.1

Hello, does anyone know how to open more than 1 instance of the app on a Mac.

  1. I have it ticked to allow opening of multiple battlenet app on the bnet option already.

    • By clicking on the app itself again, it just switches me back to the current app thats already logged in.
  2. My game and bnet is on an external drive so checking on a lot of online help to just do -n -a “App name” (in Applications) doesn’t work for me

  3. I used to be able to do it on Big Sur but due to the recent inability to update WoW (asking for admin rights tho you are already admin), I updated it to Monterey 12.0.1. So is there anything different for the Terminal app to understand?

I am not tech savvy so please explain in simpleton terms :slight_smile:

This was what was working for me:
open -n -a /Volumes/Extreme\ Pro/World\ of\ Warcraft/Battle.net.app

Its been yonks since I remembered where I found how to do it and for safety reasons I saved it in my rtf file. Now it doesn’t work. Even though the Battle.net. app is on the same path.

Error Message I get for using it is below:
The application /Volumes/Extreme Pro/World of Warcraft/Battle.net.app cannot be opened for an unexpected reason, error=Error Domain=NSCocoaErrorDomain Code=260 “The file “Battle.net.app” couldn’t be opened because there is no such file.” UserInfo={NSURL=file:///Volumes/Extreme%20Pro/World%20of%20Warcraft/Battle.net.app, NSFilePath=/Volumes/Extreme Pro/World of Warcraft/Battle.net.app, NSUnderlyingError=0x600003e94db0 {Error Domain=NSPOSIXErrorDomain Code=2 “No such file or directory”}}

***Do note that I did delete the Battle.net app among other attempts to try to fix problem (3). I have reinstalled Bnet app back to the same directory under World of Warcraft on the external drive. So does it not work with me just copy pasting what I used to do? I cant remember how I ended up with this line for Terminal: open -n -a /Volumes/Extreme\ Pro/World\ of\ Warcraft/Battle.net.app where it looks like the forward and backward slashes are inconsistent.

Again… my apologies I am not tech savvy so let me know of any suggestions with how to actually get there. I did try:
open -n -a /Volumes/Extreme Pro/World of Warcraft/Battle.net.app

and got back this error (user name changed to MYNAME):
/Users/MYNAME/Pro/World, /Users/MYNAME/of, and /Users/MYNAME/Warcraft/Battle.net.app do not exist.

Any suggestions or help would be much appreciated. Thank you!