Ground target skills not allowing me to target

Hi there,

This morning I noticed a problem with my ground targeting skill “Exploding Palm”. With the proper legendary offhand weapon, you gain the ability to ground target with this skill and leap to that point.

As of today, the targeting reticle doesnt want to move to where my Microsoft X/S controller is telling it to go. The target stays right on top of me. If I move the right thumb stick all over, the targeting is very twitchy and sometimes it looks like it will work but then it snaps back to being right on top of me. I think this is an issue with Diablo Immortal and not the controller because as I am using the right thumbstick, I can see the UI version of that stick pop up and follow where I am moving it very precisely.
Unfortunately, the ground target skill is not following the movements at all.

I tried doing a DI client repair and changing the batteries on the controller but neither of those seem to help. I also blew compressed air into the joints and stick areas of the controller. No effect.

With the client repair, the skill DID work properly 1 time. Then went back to being twitchy.

1 Like

I would like to add it’s all monk Ground target skill with legendary weapon imprisoned fist and flying dragon . Same here with me I’m having the same issue I thought it was my controller at first than I stop using controller and I’m still having it . I tried repair and even uninstalling the game and issue continues please fix this