Games stuck in Update

The application has WoW and SC2 stuck on the Update button. When I attempt to use it, it displays “Whoops! Looks like something broke”. This occurs similarly for when I attempt to Scan and Repair. Both of these are located on my HDD (F:) drive. Heroes of the Storm, however, does not have this issue, and is stored on my SSD (C:). NonBnet games on my (F:) drive operate.

I have attempted a clean install (also removing %appdata%,%programdata%, so forth, as well) of Battlenet. I could not uninstall either of these games, so I formatted the (F:) drive completely and reinstalled them. The issue occurs after restart, but not before. I have also attempted to perform the scan or update with Windows firewall off and my antivirus security disabled.


Hey there DeathlessIce!

We appreciate you reaching out regarding those update issues. Do you keep the Desktop App on your F:\ drive? If so, this could be the source of the issues, as the Desktop App needs to be on the same drive as your Windows installation to function properly. Your actual games are fine to be stored on separate drives.

1 Like

Yes, Battlenet is also installed on C.

Thank you for the response

DeathlessIce, thank you for confirming that! Can you temporarily test an alternate network such as a mobile hotspot or VPN? This will help us quickly determine whether the issues are network-related.

If you’re able to update when using an alternate network, at that point we can be sure that the issue is isolated to the primary network. If this is the case, we recommend contacting the Internet Service Provider (ISP) for assistance determining what is causing the issue to occur on that specific network. They might need to adjust network-level security/firewall settings on your modem or temporarily replace the device to narrow it down further. I always recommend requesting to be forwarded to a “level 2 or level 3 technician” when contacting the ISP since the front-line representatives typically only have access to basic diagnostics and troubleshooting tools.

I hope this helps!

1 Like

I attempted as such using my phone as a mobile hotspot. This did not resolve the issue.
I also downloaded and ran Starcraft successfully on a separate device using my usual connection.


If the issue is only happening on games that are on another harddrive, usually that’s going to be one of three things - a security program (Third party or defender) admin issue (due to registry corruption) or an issue with the data on the harddrive or harddrive itself.

I’d uninstall any third party security programs you’re using, restart your PC, then run windows update over and over until you pick up everything, especially windows Defender updates. Even if it says you’re up to date, don’t be so certain. We’ve seen several instances where the automatic update doesn’t pick things up, so click that “Check for Updates” button.

If that fails, you’d want to test from a new admin account. If it works there, it means your old admin is corrupted, and you can move your files to the new account and delete the old one or work with Microsoft to repair the old one.

And finally, if even that doesn’t work, you’d want to reinstall the games on your F:\ drive and if they continue to have update issues after reinstall, reinstall them on your C:\ drive instead. If you get to that last step, there’s likely something going wrong with the drive itself so you might want to have it tested at a PC tech or reformat it and see if that fixes any errors with it.


This is happening to me also. Game is on the same drive as battle

My game did the same thing a few days ago so I looked into how to fix it and checked all of my drivers and OP system and everything was good,so I fallowed what was next in uninstalling the Battle net app and reinstalling it and when I do it starts the download and gets about half way to 3/4’s of the way then just sits there doing nothing. I have let it sit there for 2 to 3 hours with no progress.

So my problem was somewhat different than what is described by TWIZTDLO. My issue was that I clicked “Update” or “scan and repair” and the game would show the error “Whoops! Looks like something broke" immediately, with no download bar. Furthermore, games only worked on my C drive, but not work nor be detected (when I installed Bnet) on F.

However, I have resolved my error.
To test if it was a networking issue, I tried:

To see if it was the hard drive:

  • I tested another game on the drive.
  • I formatted my separate drive and installed cleanly (be very careful attempting this).

To test if it was application:

  • I uninstalled Bnet.

  • I also deleted any additional Bnet folders as described here.

To test if it was Windows-related:

  • Checking for WIndows Updates and restarting, many times.

  • I tested from a new admin account.

  • I ran the System File checker from the command line.

After running the I system file checker through the command line, it informed me of errors. Since I didn’t want to play with this (i’m not too tech savvy), I simply clean reinstalled Windows. I am actually unsure what specifically was the problem, but I suspect it was a Windows registry issue. I doubt this is the common case, for most, so don’t start here.