Fix for Linux/Lutris users stuck in update loop

Seems to be working now. But I did it differently.

First of all, I didn’t replace any of the Agent.exe files. I have the old Agent.7984 folder still. So I pointed the bnet duplicate to the Agent.7984/Agent.exe, and the original to the standard launcher file.

I’m using lutris-fshack-6.21-6, and I’ve disabled both fsync and esync. Not sure if the latter matters.

And I cleared out the cache folder.

What made the difference for me was allowing the bnet launcher to handle the different Agent.exe files itself, and pointing to my 7984 folder instead.

Edit: I also switched to the beta version of the bnet app.
Edit2: I also switched to windows7 in the wine config for the prefix.
Edit3: It got stuck on “Reclaiming space” for all WoW flavors, but closing down the prefix and all running processes, then starting up again with the old Agent.exe first, then the launcher, that solved it. Updates were able to finish.
Edit4: I enabled fsync and esync on the restart, seems to be working.
Edit5: The game can’t be launched at all from the launcher using this runner, though. Crashes at startup, so I have to run the game exe manually through another prefix with another runner.

First of all, I didn’t replace any of the Agent.exe files. I have the old Agent.7984 folder still. So I pointed the bnet duplicate to the Agent.7984/Agent.exe, and the original to the standard launcher file.

What exactly do you mean by this? Did you symlink some file to Agent.7984/Agent.exe? If so, which file?

I mean exactly what I wrote, I just wrote it kind of messy.

I did not change any of the Agent.xxxx folders at all. This is what I meant.

So in the 2nd lutris entry, the duplicate of the first, I run the drive_c/ProgramData/ file. With this running, I can start the bnet launcher as per usual, and was able to update the games.

No game would run in this prefix anymore, though. So I made another prefix with windows set to 10, lutris to my most recent and so on, and ran the games manually through that. Should also be noted that we have to manually (or by lutris shortcut like above) run the Agent.7984/Agent.exe file before running the games if we want access to bnet chat and friendslists.

And I didn’t need to symlink anything to Agent.7984/Agent.exe, because I had that folder and its content already.

Agent 8020 fixes these issues

Howdy Everyone!

I do apologies we didn’t post here sooner but the development teams was aware that a recent change did cause havoc with Wine and the software used for Steam Deck. This wasn’t intended.

A fix was deployed and it appears it’s working. If you are still having issues please try a reinstall of the app so it fully updates to the 8020 build.


So is it also safe to turn esync and fsync on without WoW randomly freezing (for me mostly after some hours)?

Thanks Blizzard for the quick fix.

Thank you!

The WoW PTR doesn’t start anymore, complains about unsupported video card, just heads up.

1 Like

I never ran into this except when I leave running in the background, will randomly freeze after a while and take down wine with it.

1 Like

thanks for the fix blizzard!

Yes, same here but WoW also froze randomly w/o using the bnet launcher at all. I saw that I got the new agent w/o even running the launcher (/home/USER/Games/battlenet/drive_c/ProgramData/, so I guess it’s also used by the game client, talking about wotlk classic in this case.

Wow, thank you so much! I’m reinstalling everything now. (Had to factory reset from experiments gone wrong)

This is the funniest unintentional breaking I’ve ever seen, TBH. I think y’all even released an agent in an attempt to fix it that was just as broken as the others. I won’t hold it against y’all, but please respond a little sooner to say it wasn’t on purpose LOL.

Thank you so much. It seems to work. Now i can change the launcher back to bnet instead of starting D3 directly and have to enter the auth code every time… :slight_smile:

Thanks Blizz

This is happening to me too, on beta and ptr but not retail or classicwotlk and It was working last weekend 17th Sept not sure when it stopped working but same issue. Not expecting any official support but just raising awareness.

Thank you. Appreciate that this was done.

Thank you so much for this!!! Jubilant /salute to everyone!!!

Thanks a lot Joynueer.
Now can you fix the PTR and Beta Linux game prerequisite detection ?
Since now we are able to update, we saw we cannot connect anymore on PTR and beta since this week build, because our hardware is recognized as outdated

Please forward a thanks to everyone involved in the fix. We know Linux is not officially supported, so this is a great kindness to fix bugs affecting us. We appreciate it very much.


I only just heard about your post. Just wanted to chime in and thank you for the swift action and addressing us directly.

Keep up the good work!