Elder Rift Party Consumed Crests

I was in a party for an Elder Rift which I had selected a Legendary and Rare Crest for. Upon entering the rift, I was promoted that my connection was lost and would reconnect. Once I was reconnected, I was still in party, I went to enter the rift again but I was now missing my two crests.


I had the same thing happen to my Friend. This blocks them out of progressing the guide until they get another legendary Crest. :frowning:


I also had this happen to me. Had just completed an Elder Rift with a friend who had used theirs. Afterwards, I noticed I didn’t receive credit on the Guide for Westmarch 2/16 for completing an Elder Rift Enhanced by a Legendary Crest. Upon trying to start the next Elder Rift with my own Legendary Crest, I got that connection error message, and indeed the crest had been munched.

Now I can not progress the Westmarch Guide without getting another Legendary Crest.


I am experiencing this issue. I am now soft locked after losing that free crest. Wish I could keep playing.

1 Like

Having the same exact problem. Has anyone heard of a fix for this or do we have to start a new character?

1 Like

Have the same issue :frowning:

At least it’s possible to progress the main quest after completing the rift with any crest (rare can do) but the guide won’t be completed. It would be amazing if we could get 1 legendary crest back by in-game mail, cause the only way to pass the guide now and get the legendary crest is by paying real money. I have a budget for this game but I would love to spend it on some bonuses instead of the parts of the game that otherwise should be free :slight_smile:

To make it easier for devs, it was on:
Server - Cathan
Character name - Lenny
Account tag - Lenny#23747

I’ve got my legendary crest back through in-game mail - love you blizzard <3

Me too. Same problem. I have a completely blocked quest line and slow progress in battlepass. I wouldn’t have reported it if it wasn’t practically impossible to get a new crest without paying.

1 Like

Hello there, I ran Elder Rifts with 3 Rare Crests and for some reason my connection was lost. My party restarted it again and I clicked “Accept” and again it was bugged. To my surprise my 6 Rare Crests were gone and I was not even inside the Elder Rifts. I checked my mail to no avail. I even tried relogging and unstuck but it didn’t work. Please refund my 6 Rare Crests. This bugged scares me to spend another dollar in the game if this is not corrected.

BattleTag: OrcBerserker#11230
IGN: 4Runner
Server Name: Blood Raven
Lost Item: 6 Rare Crests