Downloading WOW Initializing stuck on (2145571)

We recently upgraded to Window’s 11 and had issues with WOW, so we uninstalled it figuring it was corrupt. Now we are unable to reinstall the program. We are able to install When we try to install WOW (live) the installation loops while trying to initialize (2145571). I am able to download Diablo and World of Warcraft Classic without issue, just not WOW (live). I have updated by drivers and ensured everything on that machine is working properly. I uninstalled/reinstalled, cleared the cache and even removed the folder from my program data file. Any assistance would be greatly appreciated. Thank you in advance for your assistance.

1 Like

Tried a bunch of stuff just now myself and saw someone from a couple months ago mention to exit Steam first. It worked for me so far, exit steam and reengage the download, got passed the 2145571 stuck, now downloading appropriately.

Same problem here. Tried everything. Several re-installs.

It just wont’ do.

Blizzard Tech-support - this is clearly an updater problem.

1 Like