Diablo II installer File Doesnt work right

I purchased Diablo 2 LOD from the blizzard shop,

it gave me a key, the downloader_diablo.exe downloaded and i ran it as an administrator,

as soon as it started up, the following errors popped up.

Script Error: Object doesnt support property method or Keys
Script Error: Script Error, URL: (Extremely long URL not gonna post it here)

once i got passed them it downloaded the installer files, i click run as administrator on the Installer and loads up the pop up window where it says Play Diablo 2, exit installer, etc…

When i click on play diablo 2, nothing happens, i tried unistalling and nothing happened there.

I paid 10.59 for this and it should be working… i may have to ask for a refund if it cant get it to run on my windows 10 laptop.

Hey there,

The Script Errors are a known issue with the old Diablo 2 installer, but they do not affect the install process so you can just bypass them.

If the game does not launch when clicking the Play button it may be due to security software preventing the game from running properly. If you are using any anti-virus or security software try temporarily disabling the real-time protection or shields, and then see if the game will launch again.

There should be a Diablo 2 icon that was placed on your desktop during the install as well. Try right-clicking and selecting run as admin on the desktop shortcut to run it from there.

I tried bypassing them and got the same problem trying to load the game… clicking play diablo ii LOD does nothing. I tried disabling my Anti-virus software for the moment before redownloading and installing and still got the same issue. I even tried doing all this on another computer that was just freshly installed with windows 10 a month ago and that actually worked. Why this worked after everything else had failed is a mystery…

Hi all!
I had the same behavior of the installer and also during the installation process. Reason why without any installation the installer just said “play diablo2: LOD”: I had an old version of Diablo2 and Diablo2: LOD installed. After deleting/uninstalling the old directory I got “buy Diablo2”.
Why is that?
You need to download and install Diablo2 first. Diablo2 LOD does not work without the main game - it’s an expansion.
So make sure to download and install both games after deleting old instances of the game/expansions. You can keep your old char saves by copying the saves dir.
Have fun looting and leveling!

Sat here for hours now looking up videos and reading posts. Not a single thing has worked. It says this app cannot run on this computer when I try to use the downloader.

I recently had the same problem with the DII file. Hit CTRL/ALT/DELETE then TASK MANAGER, then PROCESSES. Find that file and end process.

I had the same problem, I found out that the installer looks in windows registry if the game is already install.
So
#1 - open regedit, ( Click windows button + r , regedit,
#2 - Inside regedit, click Edit->Find
#3 - put diablo for the text to find
#4 - Click find next
#5 - Delete all old diablo 2 references ( click on F3 to find next )
#6 - Launch the installer
#7 - It will now show install Diablo 2 instead of run diablo 2
#8 - After installation go to your Battle net account and copy paste the CD key, you can not use your old cd key from the cd, you need to register it inside your battle net account.
#9 - Play game :smile:

I ran into an error while the game was trying to download the patch.
Go into your installation folder
shoud be : C:\Program Files (x86)\Diablo II
and run BNUpdate.exe

VoilĂ  !

3 Likes

I am also having issues with d2 and d2 lod installs… keep getting script errors and game does not run properly if you by some miracle do get the installer to run… this is a corrupt download and needs to be addressed.
Fresh laptop… brand new gaming spec… no d2 installs present … still having issues… its a corrupt download it has been for years… bllizzard just needs to get off their lazy Asses and provide a good working install for people to download from instead of having to find sketchy 3rd party websites to download from that may or may not contain virus/keyloggers/etc. Why is there not a valid working download available on blizzard for the people who actually purchased the game from blizzard?

1 Like

I’m on the same boat with person who posted 3 hours before me. Install had the normal script issues everyone is talking about. However, after by passing those message, the install ran smoothly.

I hit play diablo and click on battle.net. Immediately, it starts downloading the patch. Right when the patch is at 80%, I get a “file is corrupt” message and closes the game.

1 Like

It loads up but when I click to get past the screen it hangs up with:

Halt!
Location: Line #108
Expression: Unrecoverable internal Error 0051cd2o…

It used to work once… even had LOD on it

wah
:face_with_symbols_over_mouth:

Despite that error message, the patch does seem to apply correctly.

The initial download is 1.14b and the patch updates to 1.14d. After the corrupt file error, when I relaunch the game, it shows 1.14d and runs without any issues.

thx a lot. this solved my issue. I had to delete the entries from my Registry :slight_smile:

I can’t even get the game to open the installer. What is the deal with that I tried every piece of advice from compatibility, to admin, to no antivirus and nothing. Forget launching the game I can even install it.

1 Like

i’m having the same issue. Installer does not work. I am running as admin, compatibility mode (windows xp), 16 bit color, and nothing happens when I try running the installer. Help, please