Diablo II battlenet issue

so I have owned the D 2 LOD expansion for a while. disk version with cd key. im trying to connect to battlenet to dungeon crawl old school with my friends and it tells me it cant recognize my version? Also, I installed the battlenet app to help the process along and when it asked to locate an already owned game on my pc it cant find, nor can i manually find the installer. This is all while the game is functioning on singleplayer simultaneously. I attempted to manually find the installer on my pc, copy and paste under battlenets locate game and it turns into an unusable file. Anyone else hit this problem?

Hi there,

Diablo 2 has since evolved into a version that is downloaded and installed. You will need to bind your old disk install game keys to your Blizzard account. Before proceeding, be sure that you are signed into the Blizzard account that you wish to bind the game keys to.

Step 1: Head to your Blizzard account overview.

Step 2: Enter your Diablo 2 game key into the “Redeem a Code” field, click Redeem Code. If you also have the Lord of Destruction expansion, repeat the process for that key. This process converts the old 16 digit keys into new 26 digit keys and binds the games to your Blizzard account.

Step 3: Go to Games and Subscriptions under Classic games. Here is where you can download the game client and reference your new 26 digit game keys for installation when prompted. Before installing, you should uninstall your current copy of the game.
If Diablo 2 doesn’t show up right away after redeeming your keys, give it a few minutes.

After installing if you have trouble connecting to Battle.net, or the patch downloads but doesn’t appear to fully install, you can try manually downloading and installing the latest patch for the game from here.

I hope this helps.
Have fun!


Hi there, I have the same issue only I have never had a previous version of the game installed. I used the 26 digit game key I converted from my original game discs, have no issues installing, but once i go to play, it says I need to insert my expansion disc.

Give this a shot:

Also, are you are installing through the installer from the Games and Subscriptions section of your Battle.net account?

:arrow_down:Copy/paste below link to your browser :arrow_down:

Bah, lost my TL3 status, can’t post links anymore. :man_facepalming:

So funny enough, this did not work for my Windows computer but since the link you provided had options to download the installers for Mac, I tried there on my 2009 MacBook Pro that’s still chugging away and it worked there!