Diablo I not available for purchase, please help tried every


I wanted to buy Diablo I on the shop but the option is just not there. When I go on the battle net store, either the app or using a browser, the Diablo I page is just an empty Diablo header and nothing more. Even Warcraft II is available to buy but not Diablo I !

I tried everything, removed the cache, cookies from the app, from the browser…
I tried to find the direct buying link on Google but when I go to the correct webpage, (link is without the two spaces, obviously xD) ( https:// us.shop.battle .net/en-gb/product/diablo?p=1652215 ) I just have a void with “Hmm…looks like there’s nothing here.”

I feel helpless and I think I’m going insane lol.


Do you see it with this link?

1 Like

I have the same issue

1 Like

Unfortunately I still have the same issue… “Hmm…looks like there’s nothing here.” :sob:

I can see the store page normally on my phone. I can’t check my PC or the launcher at the moment.

I’ll pass this on to Bliz.

I login from Italy, if i use the normal connection, Battle.net don’t show the purchase page, same on my phone.
By activating the Google One VPN, the purchase page appears.
Same issue on Battle.net app

With all the issues is it possible it’s showing up less or not at all until they figure things out?

With what Arthas says (not showing on a local connection, but is showing on a VPN), it sounds like something to do with their area.

Best bet would be to ask Support if they can tell why it’s not appearing for some people.

Same problem in France, as for War1. (War2 is ok)

1 Like

Have you tried via GOG, they include better support for modern Windows as well.

Okay a little update, this is really odd.

On a browser, when not logged in but using a VPN I see the Diablo I store page fine.
But then, when I log on the battle.net website to buy it (still under the VPN), the store page disappears and “Hmm…looks like there’s nothing here” comes back…

Edit : I’m from France btw.

Fixed 1CHfbtR3DQP6e4JQ2nJe9wyxVMvWYUSLhA

It’s not on my end. Still the same problem. Made a support ticket but nobody’s answering…

If it successfully submitted (you got a ticket number), they will answer. It’s just a matter of your ticket coming up in the queue.