Diablo I Classic Easy Fix Working

To easy fix all problems with running Diablo I Classic on modern systems and computers You must use cnc-ddraw (GitHub - FunkyFr3sh/cnc-ddraw: GDI, OpenGL and Direct3D 9 re-implementation of the DirectDraw API for classic games for better compatibility with Windows 2000, XP, Vista, 7, 8, 10, 11, Wine (Linux/macOS) and Virtual Machines).
Download and unpack to Diablo Folder and set the settings. It’s works with all game modes like Battle.net and Singleplayer. Also with Hellfire.
Enjoy!