Diablo 2 installer not allowing me to install

So, I downloaded the game client from the download page via my account on https://www.blizzard.com/en-us/download/. I ran the install and while I was I saw a 404 on the image window and it said peer-to-peer networking is disabled and that the tracker is not responding. I let it finish the install and then it popped up the installer window that gave me the options to Play diablo 2, View the manual, Customer Support, uninstall, and then exit installer. When I click on Play Diablo 2, It does nothing, relaunches the installer and plays the music again. I have run it as administrator and restarted my computer and install it after a restart. I am running into the same issue, I think the issue is that I’m not actually downloading any game data, I see the Mac OS installer in the installer.app -> contents folder but I installed the Windows version so I have no idea why that is there but aside from that it’s looking like it just has the installer data and nothing else. Please advise.

2 Likes

i’m guessing you had D2 installed at some point before. we can get around this by deleting 2 settings in the registry. be very careful when using regedit, as it has potential to cause great harm to your Windows installation. i recommend backing up anything you intend to delete.

  1. open regedit
  2. navigate to HKEY_CURRENT_USER\Software\Blizzard Entertainment\Diablo II (left pane)
  3. (right pane) look for “InstallPath” and “UninstallPath”
  4. delete just those 2 settings
  5. close regedit and re-open the installers you downloaded. you should have the option to Install rather than Play.
13 Likes

That digital world it full stupid.

1 Like

omg that worked perfect for me, took me a while to find a solution for this. Thank You!

[Edited by Blizzard] This thread has been inactive for some time. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion. Locking this thread.