Diablo 1 still buggy as hell

the game closes randomly now.
you can’t play over battlenet due to port problems that arnt really there to pose a problem.
and it took me forever to even connect to battlenet due to major account creation problems.

1 Like

Hey Dahca,

The version sold on Battlenet is the same version that’s been available for years.

It is not updated, remastered, etc. It’s made available “as is” meaning it’s up to the users/community to get it working.

This seems wrong.
Why do this to us?
It is not a working game.
If you want us to try to make it work, it should be free then.

So you are saying, I can use all sorts of 3rd party programs in the hops of making or work?
Please give me a list of Blizzard recommended ones at least.
The game don’t know that its 2024 at all.
It thinks its looking for DirectX 3
It is not compatible with much of anything in its current state.
It don’t even know where to look for the internet at for multi player, its looking for dialup or something.
All the other old blizzard games where made to run on todays computers, why did this get left in the dust?

I am not a programer…

1 Like

Bliz rarely recommends any 3rd party fixes since they can’t vet them. However, of the four main issues, there is a support article for one, a support article for another (the paragraph about port fowarding), and a community website for the other two. Specifically, “Patch #4” for crashes and “Patch #1” for conneting to Battlenet.

It’s not just D1. WC1 and WC2 are also available “as is”. Other old games like SC1 and D2 were remastered in recent years. That’s why they work on modern systems.

All that said, GoG sells an updated version of Diablo 1 that will work on modern systems. It’s the same price but also includes a high rez mode as well.

and not through battle.net does the game work properly?

As pointed out above, it’s being sold as it was when it received its last patch in 2001. No updates or remasters since.

In other words, it’s being sold “as is”.

I got Diablo 1 working by making a shortcut on my desktop and right clicking it and run as administrator. Unfortunately, that doesn’t work for Diablo Hellfire. Still trying to get the expansion to work, when I run it as administrator, I get a black screen and then it takes me back to the desktop.

Hope it works for you!

Have you tried using DevilutionX for running the Hellfire expansion?