Diablo 1 multiplayer...black screen then exit

I have installed D1 on my system. I have it running as admin and also compatibility mode for XP SP3. Game starts and when I go to join MP, the game goes to a black screen, makes a sound then exits. I have my ports 6112 to 6119 forwarded correctly. I work in networking as a job so please do not tell me I did it wrong. The game is just not loading multiplayer. Any ideas?

Single player does not working either. Same thing, black screen, sound, then exit.

2 Likes

I was having the same issue, the only way I can play is going to the folder and running Diablo.exe as admin, not DiabloLauncher.exe. This way I can play IPX only, battle net thing still not working.
It has been a really frustrating experience, I am also a network engineer, but who cares, not blizzard lol

100% they have not tested this thing at ALL.

On a note, it was another whole novel to make IPX work… complete garbage.

1 Like

Well removing run as admin and compat mode made it work now. But I am in an update loop. I log on, it updates, says network upgrade failed then it wants to update again.

What I don’t get is how can blizzard release a game for sale that is broken? Isn’t there laws against doing stuff like this? It’s like releasing something that does not work and charging money for it. It should be a law preventing stuff like this from being sold to the public. Shame on you blizzard for not doing your job and selling broken software. Really. One of the last things I’ll buy from you guys.

Is this what blizzard is now? A bunch of 20 something devs coyping and pasting from github? I’ll take programmers that are min 50 years of age tyvm.

I can’t do anything with MP. Same as anyone else. Port settings are fine. I just get a loop of an update.

Single player would work for about 5 mins and then crash out. But…

Next to the PLAY button on the Battle.net client app, there is an OPTIONS button. I used the SCAN and REPAIR function. It did say it repaired the files and now single player is working fine. I’m in the first level and killing stuff. No crashes on single player so far after that repair, but I have only played for about 60 mins. total.

Tried running as admin and does not work for me. blizzard load cutscene + sound–> black screen.
I made sure direct X was installed as that was one of the prompts it was telling me to check.

For multiplayer to work you have to add the Global Gateway (the one setup for GOG, I can’t post it as the forum thinks it looks like a link and I’m not allowed to post links, so you might have to Google a bit), and setup port forwarding in your router.

If you have graphical issues you can try using a ddraw.dll wrapper to redirect the graphics to a modern API.

If you have stability issues I would suggest trying DevilutionX as most known issues have been fixed there (note I am one of it’s developers).

Hope that helps some of you.

1 Like

Ajenbo is referring to something like this
Github cnc-ddraw

This patch has single-handedly fixed all memory errors, crashes, and graphical glitches while in-game. The most prominent graphical glitches were in battle.net upon login where you might get black squares inside buttons and the UI just not looking right.

No compatibility settings applied running the game from the “Diablo” desktop shortcut on a latest build Windows x64 machine with 9900K and 2080Ti.

Honestly, this patch should be included with the game to remove most of the performance frustration.

The only thing left to do is to adjust router, firewall, and possibly antivirus porting to create games and so other people can join games.

2 Likes

Ditto.

Completely smooth and all graphical errors/glitches are gone.

It looks and performs as good as GoG’s version now.

It can be used for WC2 and D1.