Diablo 1 fails to start with DirectX error

I just picked up the original Diablo off of Battle.net along with the first two Warcrafts. The Warcraft games run fine, but Diablo fails to start with a “Direct Draw Error”, saying in short “Diablo was unable to properly initialize your video card using DirectX.” It goes on to tell me that I can install DX3 using the Diablo CD.

Error is:
Not implemented
at: dx.cpp line 183

Any ideas? FWIW, running an RTX 3080 on Windows 11 with DX12 installed, but I figure the assumption is that I’ve at least got DX3, so not sure how helpful that is.

Thanks!

EDIT: Ended up finding the answer elsewhere. Running Diablo.exe directly works fine. DiabloLauncher.exe will start but throws the same error if you try to launch Diablo from it.

3 Likes

Having this same error. I have an updated DirectX and DxDiag shows nothing out of the ordinary. Any help on this would be fantastic.

I also purchased the game within the last two hours.

I have attempted running from diablo.exe and from the launcher. Both continue to give me the same error.

1 Like

Having this same error

  1. Search “directx_Jun2010_redist” on google, navigate to the microsoftDOTcom homepage(should be the top search result).
  2. Download the file in your language.
  3. EXRACT THE FILE IN IT’S OWN FOLDER.
  4. Go to the folder and run the exe file and install.
  5. Go play the game ^^
1 Like

its not working, any other idea?

EDIT: SOLVED!!! I managed to run the game now and it only required a few sterps.

Click on the settings icon next to the “PLAY” option of diablo 1 in battlenet and click explorer mode to open directory. Open diablo folder and look for diablo executable (it has the icon of the game). Right click and select property and run compatibility mode. It will ask this:

“Are you trying to troubleshoot this executable program: C:\Program Files (x86)\Diablo\Diablo.exe?”

Answer yes!

It will then ask “What is the problem are you having with this app?” and out of the 3 options, select “None of the above” because its not a display issue or permission issue.

It will do some short diagnostic and ask the following:

“Do you want us to apply recommended compatibility settings for you?”

Answer yes. It will then say: “Please try your application again. Did this solve your problem?”

In my case it did so you can click yes and close it.

7 Likes

The directx_Jun2010_redist worked for getting it going.
Still has a fault that if you tab off the game it closes but I have been able to play otherwise. Perhaps a solution overall is closely related to this.

1 Like

It didn’t for me. I saw someone also had the same issue even with the directx_Jun2010_redist process.

Hey all,

Have any of you tried to launch the game directly from the diablo.exe file in the installation folder?

The OP mentioned:

That’s also the workaround that Bliz is asking people to do.

2 Likes

Hi Leviathan !
Thanks for the work around. It does work. Unfortunately it also runs in 640x480 in my big screen? How could I play fullscreen in the game? Any ideas?

Thanks it worked this way.

Work for me! thank you

Shoot. Back to not working no matter if i open in diablo.exe and with the directx file mentioned above.

I don’t know if its related, but It usually takes me 3 tries on average for the game to make it to the first selection screen. After that Single player seems to work fine. Battlenet sends me in the infinite loop even after trying all the network settings already discussed on these forums.

Issue: Unable to launch from bnet launcher.

Work around steps:

  • Attempt to launch directly from game folder instead.
  • Installed directx_Jun2010_redist,
  • Ran in compatibility mode for Windows XP SP3,
  • Single player works.

Current Result: Any attempts to get multiplayer to work otherwise crash the game immediately.

Expected Result: Should launch from Bnet launcher without issue and all game features should function in single player/multiplayer.

Notes:

  • DX Error attempting to launch from bnet
  • Initial Intro Videos/Company Splashes do not play
  • Pressing escape too many times will exit game from main menu trying to skip blank Videos.
  • Playing on 4K TV causing graphical oddities with menus.
  • Alt tab crashes game.
  • Stuck in low resolution mode as well.

System:

  • Windows 11 Pro
  • 64 Gig Ram
  • M2 Drives
  • GPU: RTX 3080ti
  • CPU: Ryzen 5800x3D
2 Likes

Anyone else having issue to fix resolution? mine takes a small portion of top left screen and the rest is black, even if i change my monitor to a lower res. atm the game is just unplayable

One would think that Blizzard would want to start putting there best PAW forward given all the heat they are taking of late.

“dx.cpp line 183” this means that the game was unable to set your screen to 256 (8bit) color mode.

If none of the mentioned workarounds work for you there are basically two options, you can either run the game via DevilutionX or add a DirectDraw wrapper dll to the game folder that redirects the DirectDraw calls to a more modern graphics API.

Hope that helps.

1 Like

Works for me aswell. Thank you !!

Worked! Thank you for posting!