Diablo 1 Blizzard/Battle.net

Okay, I think we’re figuring this out (with the help of Xcluusive too).

All three Configuration keys have the 4 gateway subkeys inside?
(By Keys, I mean the things that look like folders.)

I’ve only checked that one entry. I didn’t know there were others but I’m looking.

Look inside all three “Configuration” keys (folders).

Is it different than:
The one under Battle.net has the 4 gateways.
The one under D1 has just the Global.
The one under W2 has just the Global.

I think I found the issue… hopefully.

  • Battle.net
    *-Configuration ← D2LoD gateways
  • -D1
    *—Configuration ← D1 “blizz launcher”

Both have

U.S. West
U.S. East

1 Like

When I deleted the D1 key and ran the Bliz version, it displayed the 4 gateways. So it must have been pulling them from the Battle.net key.

When I re added the D1 key, the Bliz version went back to displaying Global, meaning it must have pulled from the D1 key.

So what if we wipe the D1 key that has the 4 gateways, and merge in one that has the Global?

1 Like

I have only two folders in that tree…

/Battle.net/Configuration/… with only the four original servers.

/Battle.net/D1/Configuration/…with only the four original servers.

Exactly as listed by Excluusive.

Okay, that’s fine. That just means you haven’t installed WC2.

Do you mind if I add you on Bnet?

Certainly. Appreciate your help and everyone who is working though the issues with us.


i already changed it to the global gateway hours ago (added it to the list)
the problem is we don’t know if thats the intended config. when you install the game from the launcher it gives you the 4 gateways. west/east/asia/europe

the only reason i mentioned the global server above was because i seen it in registry with the GoG version and tried it. that doesn’t mean its suppose to be set that way. if it is. the fix will be pushed out when someone reads the forums. :rofl:

I’m with you on that!

Lion and I ware going to try some Registry shenanigans tomorrow. If we find the right combo of changes, I’ll pass it on to Bliz.

1 Like

Okay, some good news.

When I tested my possible fix on my laptop, I got rid of the update loop!

I installed D1 on my laptop which has never had GoG’s D1 installed. Like you pointed out, Bliz’s D1 writes the subkey with the 4 gateways on it, which when connecting to them in the game causes the update loop error. I tested my fix and it worked, no more update loop.

So this bodes well as a solution. LionHeart and I will try it tomorrow to see if it works for them too. If it does, it’s safe to say that this is the solution to the update loop errors. If it works, I’ll pass all the findings on to Bliz.

1 Like

Thank you all for this information! Adding the global gateway fixed the update loop for me.

For anybody just reaching this post, it appears that the Battle.net install of D1 does not include the newer ‘Global’ Battle.net gateway. Instead, it installs with the older 4 regions. To fix the issue, open your Registry Editor and find HKEY_CURRENT_USER\SOFTWARE\Battle.net\D1\Configuration. Right click on the item labeled ‘Battle.net gateways’ and click modify. Below the very last item, paste the following three lines:


Open the game and select Multiplayer. Before you try to join Battle.net, click ‘Change Gateway’ and select the new ‘Global’ gateway. Then, you should successfully be able to login to Battle.net.

1 Like

I made that change to the registry and chose the Global gateway and it seems to be working fine now. Appreciate everyone’s help.

Seeing that the four legacy gateways don’t work, they can possibly even be deleted from the subkey.

When I did my testing, I just replaced the “Battle.net gateways” subkey completely, which is the equivalent of deleting the four legacy gateways:

1 Like

For a little bit of context, when the game logs in to bnet it sends a fingerprint of the application, if this is not recognized by the server it will tell the game to trigger the update process.

Various tweaks that where done to the game files in order to run the game on modern systems affect the fingerprint, and if the servers where not adjusted to recognize the new fingerprint then it will end up in this loop.

Hope that is a little helpful.