D2R chat not working

We have to communicate with overhead chat. It worked at the start, but nothing has worked since except for ! chat.

Here are the forums for the D2R Beta.

That would be fine and all, except that the forum isn’t opened up to Beta testers. It is locked if you weren’t in the Tech Alpha it seems.

Try logging out and back into the forums.

Just did that, and I still get this message. " You must have access to the Diablo II: Resurrected Tech Alpha to post on this forum."

Okay, I’ll pass that on.

My sincere apologies, please disregard. I was logged into an old account in which I did NOT have beta access on. It works on my main account.

Lol. Just came here to ask you if you had more than one Bnet account!

Glad you got it all figured out! :blush:

D2R chat stopped working last night. Don’t know if it is server wide or just affecting me. I can’t send or receive in-game messages or whispers. It’s incredibly hard to play multiplayer without it.


I have the same problem. It worked briefly on release day for me, but never since then. super annoying as i found some people in games who were probably great but no way to chat to them


I get the same message as the above; the same message for ingame whispers and battle.net client whispers marks same error.

Please use the D2R forums to post about issues in that game.

This forum here is for technical support on legacy games… Diablo II (2000) and Diablo II: LoD mostly.

Good luck with this.