Can't update wow because beta launcher won't update

Pretty irritated right now because I can’t update and play wow because the beta launcher is stuck updating at 0%. I can’t exit the beta and go play wow because the beta tab is locked due to the non-functioning download. It just says 0% completed and then a “Done” button at the bottom right. Please fix this issue. So far I’ve been unimpressed with the new launcher.

So far I’ve restarted my computer and that did nothing for the issue. Since I can’t pause the download my next step is to uninstall the launcher and reinstall the old launcher.

3 Likes

Having the same problem, I selected the BETA tab in settings and it keeps reading 0% updated. I’ve paused, restarted the app, logged off and on. Nothing. Even the scan and repair won’t work because the app is updating. Only thing I can think of next is to uninstall and reinstall.
Let me know if you find a solution!

1 Like

I am having this same issue. Launcher is stuck at 0% and wow classic wont start a pending update because of this.

1 Like

I found resolution!!!
Completely exit out of the desktop app.
Right click on your launcher and select open file location, if you don’t have that option simply navigate your program files till you find the launcher.
Delete the one titled “Battle. net”.
(I also deleted the beta folder, but I don’t think it helped anything.)
Next, go to your process list and end the updater process.
Once all of this has been completed, reinstall the desktop app and when you reopen the desktop app you may encounter an error message that the updater has ended and you have to close the process or what not, don’t worry about this. Simply continue on.
Once you have the desktop app up and running, go to your battle. net settings (should be in the top left), go to the beta tab, and select the option to return to the “Standard” version.
App works like a champ now!

Hope this helps, and like I said, you may not have to end the updater process or delete the beta folder, but I did and this worked.

V/R,
Deighzed

Happy a solution was found. Strangely, I came here this morning because the issue was still present. I read your solution and went to exit the launcher and magically it had resolved itself in that short time. Hope the issue is gone for everyone.

1 Like

To update, last night restarting my computer did not work to update the launcher, but somehow signing out and signing back in seemed to get it to update after a few minutes, and I was finally able to play.

However, the same issue struck tonight, and I did not restart my computer. I did close and reopen the launcher, and log out and log back in, and neither had any effect. I did your method Deighzed, and reinstalled the old launcher (it just works :P). I didn’t get an error message, it just reinstalled bnet in the same folder and started updating WoW, and after a brief Updating: 0% scare on the beta tab while trying to switch to the old launcher, the update went through.

I’m still supremely unimpressed with the cluttered mess that is the beta launcher, and equally irritated that I was unable to play WoW because of these errors. I tried to submit a ticket to make sure they are aware of this issue, but even though I had everything filled out and a dxdiag file uploaded the submit button was grayed out so I’ve given up on that front. I just hope they are somehow aware of this issue and get it fixed. And I hope they also give us an option to keep the old launcher, though I know we won’t be so lucky.

Thanks for your help and I hope you have a good day. Take care and good luck to anyone else with this issue.