Can't login to the launcher or app

Everytime I try to login I get some type of error. If I use my google account to log in I get an expired error and if I put my password in I get that I’ve attempted too many times. I have tried uninstalling and reinstalling the launcher. Deleting files in %appdata%, etc. I get the same stuff everytime even on the app. I’ve tried changing my password, which tells me to contact support where I of course get another error. This has been happening for a little while now. Was hoping a kind chap would have a solution for my predicament.

I have been having a similar problem. i contacted customer support. Some idiot told me i forgot my password. Then proceeded to ask me to give them a whole list of private personal data from the past 20 years. This looks like a scam by blizzard support. I DID NOT FORGET MY PASSWORD! (IT’S WROTE DOWN IN A BOOK.) And, I don’t think anyone can remember all the character names they played, from 20 years ago. Can you?

If anyone knows how to fix this plz msg, Blizzard support is NOT helping.

If this continues, and you have a similar problem…plz post after this post.

1 Like

I’m having a problem launching as well. I can login with no problem, but says it’s optimizing the launcher and downloading new files. Only it doesn’t download anything. It stays stuck as 1% then finally gives a 'Whoops! Looks like something went wrong" message.

So far:

  • I’ve shut down and relaunched.
  • Attempted to run the ‘Scan and Repair’ tool. Same thing - gets stuck at 1% and gives the same ‘Whoops’ message.
  • Restarted my entire computer three times.

Nothing is working. The only thing I haven’t doe is completely uninstall the launcher and reinstall it ‘fresh’.

It worked just fine before the Tuesday debacle where all of the realms were offline for almost twelve hours.

My active account says inactive cant login to game.

Members of the forum cannot assist with account issues. Open a ticket with Blizzard’s staff.

1 Like

I did contact blizzard customer service first. Try Reading the posts. See above.

1 Like

You broke all our accounts. NOW FIX IT!

1 Like

This has happen to my friend also 4-5 days ago she have already contact. With ticket 3 times now and still have not resolved the issue…

I’m responding to the OP, but the point still remains. Forum members cannot assist with a login issue.

1 Like

I can’t login to the battle.It tells me some functions can not be used.

The app is bugged. It does not honour ‘keep me logged in’, It creates itself a new instance when I start another game, then tell me I can’t log in because I have another instance of the app open.
The idea that the app is more secure because of this is … flawed.

It keeps asking me to use the authenticator, that doesn’t work. So I installed on my phone, hoping that would work, but it tells me to use the authenticator that still…doesn’t work.

This is literally where Blizzard tells you to go for help with this issue. Why are you wasting everyone’s time? Blizzard just gives MVP to people who kiss up to them, not anyone actually helpful.
For reference, the authenticator “has been moved to the app” - except you can’t get to the authenticator without logging in to the app…which requires authenticator approval. What a joke of a company.

You received instructions in a ticket to post here instead?

I’m quite critical of them, and I’ve solved thousands of tech problems, but yea sure…