Can't login to Battle.Net, connection stuck on SYN_SENT

It all started about a week ago, when I couldn’t connect to Blizzard in Battle.Net desktop app (windows 10). I tried probably all suggested solutions, except resetting network devices and disabling security programs (of which I have only built-in Windows Defender). When logging in I was getting the following error codes: BLZBNTBGS80000011, BLZBNTBTS00000028 and BLZBNTTAS00000001 (if not mistaken about the last one).

After digging around, I found that Battle.Net sends TCP requests on addresses at port :1119 and it is getting stuck at SYN_SENT. It is most likely an issue with ISP, since I can’t login to on phone with wi-fi, but can with mobile data. And therefore, usb tethering helps with login to battle net. Of course, this isn’t a solution, but rather a temporary workaround. The PC itself is connected with ethernet to the router.

Looking at logs, I can find following information:


[I 2023-01-28 09:22:11.0844] Checking Network Connection status to
[I 2023-01-28 09:22:33.0320] Network Connection Response to - CURL error: 7, Status Code: 0


[E 2023-01-28 09:25:25.0212] Failed to download url ""
[E 2023-01-28 09:28:38.0381] Failed to download url ""
[E 2023-01-28 09:31:51.0869] Failed to download url ""


[W 2023-01-28 09:22:33.0317] CurlError 7 from "" with message "Failed to connect to port 1119: Timed out���������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������" (hex viewer shows that all those characters have null value (0x00))
[I 2023-01-28 09:22:33.0318] Changing Request for handle 01284A20 to
[W 2023-01-28 09:22:33.0320] Attempts exhausted (2 total) for handle 06017168

bunch of similar errors

[W 2023-01-28 09:25:25.0211] CurlError 7 from "" with message "Send failure: Connection was aborted����������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������" (hex viewer shows that all those characters have null value (0x00))
[W 2023-01-28 09:25:25.0212] Attempts exhausted (10 total) for handle 01284A20

Connections which didn’t move past SYN_SENT:

RemoteAddress RemotePort State
------------- ---------- ----- 1119       SynSent (when opening Battle.Net)  1119       SynSent (when opening Battle.Net)  1119       SynSent (when opening Battle.Net) 1119       SynSent (when Battle.Net is open) 1119       SynSent (when Battle.Net is open)

It uses different local ports and different remote IPs every launch, except for, which is called every time.

The question is - how do I make the connections work? It looks like there are problems with either or that specific port, since there are some connections with IPs starting with which successfully connect. I allowed all ports in all IPs in range in ISP’s firewall and allowed and Launcher.exe in Windows Defender Firewall, but it makes no difference. If there is any additional information required, feel free to ask.

I had the same error BLZBNTBGS80000011 when there were no servers down.
can’t speak exactly for your issue but I had turned on some kind of built-in security setting on my router that was blocking these connections. by ISP firewall if you mean your router then these requests should be allowed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.