Cant launch / install Bnet

I found other post, and read many guides, but still the same.
A few days ago, battle.net app ask for an update, and then crash.
I remove all files (agent, shared) properly, uninstall, reinstall…

I check my connexion, remove other program, and still nothing.
Contacting the support didnt help me, cuz they respond what i already wrote and close the request, when i answering, other GM say me the same things and so on.

So, im searching for help here.

Battle.net SETUP is launching, installing, and a few sec after, just crash with “unexpected error”…

Im on mac BTW. My old one from 2013 can install bnet and launch it.

Hey, woOtzee! Moved this over to the Mac Technical Support forums. There isn’t any known issues with the Blizzard Application crashing during launching or installing on Macs at the current moment.

The crash itself is happening with the browser that the Blizzard Application uses. It looks like there’s some issues with the Core Foundation when launching the Blizzard Application. Before each of the Battle.net crashes, it shows the BetterTouchTool and a device disconnected in the Mac logs.

This makes the issue a bit more complex than what we can offer troubleshooting for on the forums. I’ll try my best with what we have to see if there’s any additional troubleshooting options we can offer :slight_smile: Please continue to communicate with our Technical Specialists on the ticket chain that’s currently open.

Looking into this a bit deeper, I’m concerned that there may be some sort of corruption or memory issue causing these core foundation loops and other issues with the MUX devices and BTT, or if its just the Xcode crashing in Catalina. There’s a few suggestions that I have for you to address these concerns.

  1. SMC Reset
  2. PRAM/NVRAM Reset
  3. Could you check if Filevault is currently active?

If it continues, does the crash have anything that says it quit unexpectedly? If so, click Report… and save the file.

If you have trouble with locating the file. Follow these steps, click here.
  1. Open the Console application by typing “Console” into the Spotlight (Search Icon).
  2. Click on “User Reports” on the left menu.
  3. This will display a list of crashes (.crash file). It will list the application, then the date. This should make it easy to find the specific crash for the application or game.
  4. Select the requested report.
  5. Select Share and select Notes.
    Note: The file may need to be changed to a .txt file instead of crash to be uploaded through the support portal.

Copy and paste the file here. Copy and paste the text file created and paste it between two ~~~ like so:

~~~
DxDiag Here
~~~

If you have issues pasting here, use Pastebin and post the end of the link. (ie. 123456 for pastebin.com/123456)

In addition to Caterpepi’s Post, what OS are you on?
What are your Hardware Specs, what Model Machine?

IF you are on any OS before Sierra, please Upgrade to
AT LEAST Sierra. (High Sierra is preferred.)

Just a few recent months ago, El Capitan WAS the cutoff…
However; I believe that El Capitan is due to be cut from
Support at any time. Yosemite and prior have ALL been
cutoff from Support. So, IF you can get your machine to
AT LEAST Sierra 10.12.6 with Latest Security Update I think
you will be fine for about another year on the OS factor.

IF you are on an OS that has been Deprecated, Battle . net App
WILL REFUSE to Install.

TimeLord04

Thanks for the chime in, TimeLord04! It’s a good callout for anyone else running into similar issues.

For woOtzee, we could pull the case with Customer Support on our end, which is why I provided those specifics. They are on the latest version of the OS available ^.^

Thanks all for the replies.

To have the less “interferences”, i do all my test in a new admin account, which is empty, the only stuff who boot is istats (which i close each time).
Nothing in boot process so, no agent or blizzard stuff in activity monitor.

I’m on last OS : Catalina 10.15.3
I’ve got imac 27 2019, 3.6 i9 with Radea Pro vega 48.
Filevault is disabled and no proxy/vpn enable.

I’ve got better touch tool, but i already uninstall and try, same result.
On this session, it’s not enable.

I tried once again, and here s the log :
For memory :

  • Launching setup bnet : ok,
  • Updating : its says ok
  • Then, its say “launching battlenet” and boom.
Mar  9 16:29:50 woOmac Battle.net[16062]: objc[16062]: Class BlizzardCore_URLCache is implemented in both /Applications/Battle.net.app/Contents/MacOS/Battle.net (0x101195ae0) and /Users/adm/Library/Application Support/Battle.net/Versions/Battle.net.11899/battle.net-core.framework/battle.net-core (0x105d42458). One of the two will be used. Which one is undefined.
Mar  9 16:29:50 woOmac Battle.net[16062]: objc[16062]: Class BlizzardCore_DownloadURLObject is implemented in both /Applications/Battle.net.app/Contents/MacOS/Battle.net (0x101195b58) and /Users/adm/Library/Application Support/Battle.net/Versions/Battle.net.11899/battle.net-core.framework/battle.net-core (0x105d424d0). One of the two will be used. Which one is undefined.
Mar  9 16:29:50 woOmac Battle.net[16062]: objc[16062]: Class BlizzardCoreURLConnectionDelegate is implemented in both /Applications/Battle.net.app/Contents/MacOS/Battle.net (0x101195b80) and /Users/adm/Library/Application Support/Battle.net/Versions/Battle.net.11899/battle.net-core.framework/battle.net-core (0x105d424f8). One of the two will be used. Which one is undefined.
Mar  9 16:29:50 woOmac Battle.net[16062]: objc[16062]: Class PHXPropertyListContainer is implemented in both /Applications/Battle.net.app/Contents/MacOS/Battle.net (0x101195a90) and /Users/adm/Library/Application Support/Battle.net/Versions/Battle.net.11899/battle.net-core.framework/battle.net-core (0x105d42548). One of the two will be used. Which one is undefined.
Mar  9 16:29:51 woOmac AGMService[15408]: ProcessPath : /Applications/Battle.net.app/Contents/MacOS/Battle.net
Mar  9 16:29:51 woOmac com.apple.xpc.launchd[1] (com.blizzard.agent.4232.AA4C011D-6C5B-41F8-A3CB-0056EA7C9032[16073]): Service exited with abnormal code: 255
Mar  9 16:29:55 woOmac com.apple.xpc.launchd[1] (net.battle.app.93756.9B073ABC-DAD1-41AC-B1C0-2628377D1205[16062]): Service exited with abnormal code: 1
Mar  9 16:29:55 woOmac AGMService[15408]: ProcessPath : /Applications/Battle.net.app/Contents/MacOS/Blizzard Error.app/Contents/MacOS/Blizzard Error
Mar  9 16:29:56 woOmac Blizzard Error[16080]: assertion failed: 19D76: libxpc.dylib + 95826 [51E3E807-9133-3605-BB5F-D59ED6404ABF]: 0x87

Found in app Supp / Bnet / Errors > Pastebin : vfWeN17x

Seems to be the lib then.
I’ll reset ram (SMC/PCRAM) and i try again.

Edit Reset ram done.
This time i remove everything about bnet in /applications, /library/app support, /shared users… preference pann etc.
Same things.

Thanks, woOtzee! The Application is crashing because of chromium. It’s required for the Blizzard Application as a lot of the news, shop, and so on, utilizes chromium. It’s hard to say what exactly is causing it though. I have a few things in mind in hopes that it may help with fixing, but it’s a bit of a tricky one!

Let's try clearing the Application Support files. Click here.
  1. In the Mac menu bar at the top of the screen, click Go.
  2. Select Go to Folder.
  3. Enter ~/Library/Application Support/ in the text field, then press Go.
  4. Locate the folders Blizzard, Battle.net, and Blizzard Entertainment in the directory window that opens and move them to the Trash.
  5. Try opening the Blizzard Application. These 3 folders should be recreated after a few minutes.

Would you happen to have any chromium browsers like Chrome, Brave, 2020 Microsoft Edge? If so, do you have any issues with these browsers?

If you do have issues with other chromium browsers, reapplying the latest combo update may fix any chromium and core foundation issues that we’re seeing within the errors.

Hopefully, these suggestions may help! If it does continue, could you provide Log Goblin files to techinfo@blizzard.com? Use the Subject ATTN - Caterpepi [BNET:3949].

This inbox is not monitored and will not send responses. It’s used to collect information for Technical Support to assist in troubleshooting.

I use GChrome every days, with no worries.
I reinstall it to try before, incase it will update some lib, but it didnt change anything.

Btw, becuz you mentionned it, i never use ingame browser to check ticket cuz it seems to load forever (but i didnt let it load really long…) i will.

Mail is sent with all the log files.

Thanks, woOtzee! There’s definitely some lines that show there’s issues with chromium and reflect the same thing as the crashes.

[0310/012050.956467:ERROR:mach_port_rendezvous.cc(307)] bootstrap_look_up net.battle.app.helper.MachPortRendezvousServer.3423: Unknown service name (1102)

Along with the Core Foundations I mentioned earlier.

I 2020-03-10 00:20:49.719737 [Main] {} Not found: /Applications/battle.net-core.framework

There wasn’t much new information gathered on the files that I could find and all things are pointing to the same cause. There’s a few suggestions if you wanted to try them out. I believe that parallels was on the system if I’m recalling correctly. Does it help to remove parallels temporarily? Little Snitch, if its on the system, is another program that can cause some service exit code errors. Similar errors with chromium that I found seem to suggest that a combo update or reinstalling the MacOS helps fix the issue.

This issue is more complex than what we can help with on the forums. If the crashes persist, please continue working with our Technical Specialists on the ticket you have open. Something on the MacOS or a program may be causing issues with the Chromium or Core Foundations that needs to be looked into more closely by our technical support team.

I installed Parallele desktop after this issue to test some stuff, but i removed it, reboot, and same issue.
No little snitch installed.

Reinstalling macOS seems to be a little extrem for me :smiley:
And already up to date.
I’ll try to check for some fixes about Chromium, or check with repair-whatever from mac.

(i had this issue since 28 february - was on beta if it helps)

Thanks, woOtzee! The reinstall and combo update is not ideal, but it is a call out that some mentioned with similar errors. I wish the file gave us a more information on what’s happening, but it definitely seems to be focused on the Core foundation or Chromium :slight_smile: If you find a resolution, let us know and our Technical Support team is there to help provide additional suggestions!

If I find any new information or suggestions, I’ll post here as well!

BTW, i reinstall Core Foundation
CommandLineTools, and merging system’s framework library, dont do this if you dont know what you are doing. But nothing change.

I try installing the mac os beta ( i hate doing it, but who know :D). thinking it will reinstall some core system.
Didn’t change either.

2 posts were merged into an existing topic: Cant download anything