Can't install new Blizzard Arcade Collection

I just purchased the Blizzard Arcade Collection and noticed an icon did not show up in for the game. I downloaded the stand-alone installer and the following happens:

I get a popup with the following messages:
Downloading new files
Updating agent
Updating then starts up and a popup with the following error shows up

We couldn’t find RTRO. Please reinstall it, or point us to its installation folder in the Settings menu.

More help: BLZBNTAGT00000975

There is nothing in the settings menu referencing the Blizzard Arcade Collection or anything called RTRO.

I tried completely uninstalling and reinstalling without success.


I also am having the same exact error, but as purchaser of the Heroic Blizzconline pack.

Same here. At first it took me forever to even find what to do. I was hoping that it would just show up in bnet… Found the downloader on the receipt. Getting the same error you have above.

Purchased the pack an hour ago.

Having this issue as well. Epic pack.

Having this issue as well.

Where do you even download the standalone installer?
(i’m using the heroic pack)

1 Like

thanks!! appreciate it

1 Like

It has just appeared on the launcher for me.

1 Like