Cant install games on launcher

Started with not being able to log into the cod cold war servers yesterday. Ended up uninstalling the game to try a fresh install. Now when I click install, the splash screen pops up and it just stays there with the blizzard logo indefinitely. Tried uninstalling the launcher, deleting all blizzard files off the pc, making a new admin account to try the launcher, and a few other things Im probably forgetting now. Im out of options and dont know what to do. I own practically every game on the launcher and never had an issue before.

Update- left it on the splash screen for about an hour and a half, it finally loaded into the install directory page. I was able to click install but now it just says “waiting” in the progress bar.


Usually when I see something like that it’s a permission error of some sort. Try temporarily uninstalling any security you’re running. If that fails, try doing the installation on a new admin account. Finally if even that doesn’t work, manually check for windows updates - it may be windows defender blocking things.

If you’re still having this problem, please create a WinMTR test which catches a disconnection. You want to restart the test every 10-15 minutes until you catch one of these problems. Once you’ve caught one red handed, run the test for about 5 more minutes. This will let us look for problems between your house and our servers which may cause this.

If you have problems with posting it due to a link error, go ahead and copy paste this into your next post, and replace “WinMTR goes here” with your test.

WinMTR goes here

Id run the WinMTR on any game if I was able to get them to install. Seems like I need the game to be running for WinMTR to work, which I cant do because it basically gets stuck indefinitely once I click “install” on any of them. As for the other things you recommended, I have tried those multiple times over the past 6 hours along with other “fixes” I found throughout the forums. I was able to play and install any of the games in the launcher 2 days ago, then all the sudden yesterday this started.

WinMTR is a tool to check each and every hop in your connection path from your computer to an end point. It checks for packet loss and for latency (slow packet transfer).

You don’t need to be logged into any game to use it. It works with any valid IP address you give it. Sort of like going to a traffic program and checking traffic between your house and New York City.

1 Like

idk if I did this right or not but this is what it showed me.

Edit: So it was my damn ethernet cord… Never had that issue before where I had internet but couldnt download games from a launcher. Traded out the cord and it works like a charm. Thanks for the help though.