Can't even download launcher

Contacted support and watched at least 10 videos, nothing is fixing it. Uninstalled all software Blizzard says may be interfering, uninstalled all Blizzard/ files, restarted modem, changed DNS, and everything else I could think of. It gets stuck halfway every time and I don’t know what to do at this point. The one time it did go through, I got the “ went to sleep” error so I repeated the process again, and now nothing works.

1 Like

yup having same issue aswell. tried turnin off antivirus, firewall, deleted multiple files, reinstalled, uninstalled wow and battlenet 3 times, restarted my computer 6 times, still nothing. when i try to log in manually from the folder it says all servers are incompatible which im guessing they updated the game and now i can’t use this version.

having same issue here

Same! Bnet is down for me as well.

Logged onto Wrath this morning, no issues. Came back this evening, and the launcher was just spinning. The friends pane to the right actually loaded oddly enough (so it’s not my wifi), but the rest of the launcher just spins forever like it was stuck.

My first thought was to uninstall and reinstall. I had to do this about a week ago, and my guild members said the same thing because the launcher was frozen. Everything actually froze up while trying to even uninstall the files, and kept showing an error message from Bnet “please close the app before deleting” and it wasn’t open. I had to manually hunt down the folders and delete them. I followed the instructions in a bunch of threads, typing the specific folder addresses in the folder search and deleting those. Dumped my recycle bin, restarted my computer.

Bnet downloads new game files, but gets stuck about 50% on “Updating Battle Net Update Agent…” I’ve tried it about six different times, with lots of different troubleshooting, and it still gets stuck. Not sure what else to try!

Please Blizz, help us out!!

Same, perfectly working until i restart my PC, then blocked at 50% with the Update agent bug.

Tried everything and now I can’t install the desktop app.