Cannot update WoW TBC - don't have administrator rights

Experienced this issue after logging out and trying to get back in less than 10m later. Cleared cache, reinstalled bnet, restarted my machine multiple times etc. None of it helped.

This prevented me from healing our raids tonight and I hope it gets fixed. Thanks :slight_smile:

this solved my issue, make sure you have a copy of your keybinds saved though.

Time machine helps. Keep a renamed copy of Agent.7531

4th day like this… No fix the community offered worked, is there any update on your side blizzard…?
BigSur 11.6.1

1 Like

still not working MAC OS 10.15.7. Verson current according to my reinstalled battle.net shows Burning Crusade Classic Ver 2.5.2.40892
Is it possible the first update that needs to run is the problem?
None of the suggestions have worked.
you removed the red triangle - this is STILL a problem

Hey everyone,

I just wanted to check in. Looks like an update was done but there is still a problem going on. I don’t have any ETA on when a full fix will be out. This is still very much on the developers radar and we’re forwarding any reports here to them. Please keep them coming if you’re affected. We’ll provide an update as soon as we have more to share.

Thanks again.

Hi. Wanted to post that I started having this issue today on my Battle.net and can’t update classic or retail on my macOS Monterey 12.0.1. I’ve uninstalled/reinstalled and still having this problem. :frowning:

There was no fix or update at all. I tried both with Beta and Standard versions of the bnet launcher, the issue is still very much here. It’s been a week now, we need a new Battle.net launcher update or a quick and dirty way to update each of your games ASAP. You better negotiate a hefty compensation for this, Season of Mastery is just out, WoW retail anniversary period is just out, Hearthstone new expansion is just out. 1/4th of our sub down the drain. We can’t play ANYTHING.

2 Likes

I tried everything mentioned here.

The only thing that finally worked :

  • close everything, delete /Users/shared/battle.net
  • delete Applications/World of warcraft
  • launch Battle.net launcher and reinstall game

Do not forget to backup your addons and WTF (keybinds, macro, …) folders

Had the same problem a few days. Finally just deleted the entire World of Warcraft folder, clicked on Install and everything was fine.

I have tried all the above and it still has not been fixed. I was very excited about playing Season of Mastery and now not only have I missed launch but I am falling behind. Please fix this blizzard or you will be losing a subscriber.

1 Like

This seemed to work for me (MacOS Monterey), can someone else try and confirm?

  1. Quit Battle.net app
  2. Quit “Agent” via Activity Monitor if it’s still running
  3. MOVE (not COPY) both the WTF and INTERFACE folders out of /Applications/World of Warcraft/classic
  4. Launch Battle.net and Update Classic TBC
  5. MOVE WTF and INTERFACE folders back into /Applications/World of Warcraft/_classic
  6. Launch game from Battle.net

This probably needs to be done each time (I haven’t verified yet, I’m still in-game) until Blizzard fixes this problem.

Hi I cannot update world of warcraft, it has updated the other games , but I keep getting an error message when i try to update or scan/repair Error 1540x8510009a. I have tried doing a ticket but it won’t let me do that either, i have tried contacting someone but cannot find how to, I live in England, how do I speak to someone about this, I have played on US servers for years thank you

im having same issue but With HOTS and i cant reinstall it i even tried reinstalling battle.net it self and that hasnt worked

Another solution for Win10. For me it was a corrupt file in the installation directory. Doing the following solved it for me:

  1. Press Win+X
  2. Select “Windows Powershell (Admin)”
  3. Type “chkdsk”
  4. If a file in your wow directory is listed, type “chkdsk /f”.
  5. Reboot and wait for it to finish.
2 Likes

simple way : delete all ,install again ,remember backup WTF 、interface 、fonts folder!!!!!!!
i tired everything ,finally give up
just 1 night donwloading
no more worries

No updates have been made and I am still unable to play the game. This is unacceptable. FIX THIS

This worked for me on windows 10. just did a chkdsk /F /R on my drive D, which has the WoW installs and it fixed a lot of corruption on some WoW Files that were the root issue. Prolly the patch before that corrupted some of my files. After doing that, battle net was able to update all my wow installs.

i got the same problem with both starcraft 2 and heroes of the storm i tryed everything mentionned and nothing changed i even tryed to unistall heroes of the storm and reinstall it but Battle.net does not let me reinstall the game for the same reason as for the updates.

1 Like

No that did not help at all.