Cannot uninstall completly app

Good afternoon, i’m here to ask for help to fix my issue.
Tried to remove the Application from windows and it doesn’t appear in the system. Plus, i try to reinstall the app and it keeps giving me this error ( BLZBNTAGT000008FC - Blizzard Support ( ) and i tried everything that’s in the article and didn’t fix my problem.
Thanks in advance, hope someone can give me a hand on this.

1 Like

same here . i can’t even uninstall. need help!!!

Hey there!

Thanks for reaching out with these details. This sort of persistent uninstall issue is commonly caused by a problem with the Windows service “WMI” (Windows Management Instrumentation). Follow the instructions on this page to reset the WMI Repository, which might fix the update issues.

If that does not fix it, be sure to fully update or temporarily uninstall antivirus programs which may be mistakenly blocking the Agent from running. More information on troubleshooting security applications here, if curious.

If the problem continues, temporarily test a different network such as a mobile hotspot to determine whether the problem is isolated to your current network.

Hopefully, one of these steps will do the trick. Please let us know if you have any questions or run into additional issues.

Seriously nothing of all your “solutions” work for almost a year. You have messed up so bad. People are simply trying to install/uninstall an app not trying to break into the pentagon…


Same sh*t here, cannot reinstall battle net.
I also tried every solution which is proposed here and other forums. Looks like my wow career ended, cancelling the subscription now.