Cannot launch on Monterey

I just upgraded to Monterey so I have essentially a fresh install and I cannot get to run.

I’ve tried everything including reinstalling it about 5 times so far. I’ve removed all the preferences and application support items, along with the items in shared items

Whenever I launch it, I get the “ closed unexpectedly” message where I can “send to blizzard”

If I start from a fresh install, the install goes well up until that point. Then when it tries to launch the app I get the same message.

Additionally I tried posting in a relevant thread and it was unceremoniously closed without response so I’ve made a new thread

Mac Pro 6,1 - 64 GB ram, 6 core

EDIT: It seemed to be getting stuck on the authentication step. I complained a lot on all channels I could find this morning and eventually it started working. Maybe somebody reset something on the server-side end? it will forever be a mystery

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.