Cannot Launch Any Games

This problem began three weeks ago. Whenever I go to launch a game (Heroes of the Storm, Overwatch, WoW), the Play button grays out to Launching, but the games will not launch. I have done a complete system update; my drivers are up-to-date and on the list of recommended drivers for each game; and I have followed the official steps of uninstalling and reinstalling the BattleNet Launcher. Nothing has worked.

Operating System: OS X Yosemite 10.10.5
Graphics: Intel HD Graphics 5000

Has Yosemite been Deprecated by Blizzard, yet??? I’m NOT sure where Yosemite stands right now, if it is still “Playable” by Blizzard Specs. It may be close to End Of Life here.

Wait for a Blue Post to chime in, of course. I know that 10.9 was EOL some time ago, so be on the lookout for Yosemite to EOL soon.

Sorry for the bad news.



IF possible, try to Update to AT LEAST El Capitan. Then try Re-Launching your games. IF successful under El Capitan, then you’ll have your answer, and prove my suspicions right that Yosemite has hit EOL here.

Good Luck.



It’s been awhile… Were you able to Upgrade your OS to at least El Capitan? Did this work for you?

I hope this worked for you.



I agree with the other recommendation in this thread. Our system requirements for Heroes of the Storm is at least 10.12 but we recommend updating to the higher OSx version possible.