Cannot install Diablo 4 stuck "Waiting on another update"

Trying to reinstall Diablo 4. Uninstalled the game now I cannot get it to install. When I try to install it immediately gets stuck “Waiting on another update” and will not install. Have followed all steps listed in the “Waiting on Another Installation or Update - Article ID: 14236” page (can’t post links) and nothing changed. I have uninstalled and reinstalled twice and this has not changed anything either Diablo 4 still won’t install.

Help would be greatly appreciated.

1 Like

I ran into this problem today. Here is the solution)

If the error just doesn’t go away, the problem may be with the client’s Update Agent. , which is looking for updates for the client itself. It should just check for updates and install them automatically if they are found. However, if the problem persists, it means that an error has occurred in the process, and you should fix it using the task manager.

Use the keyboard shortcut Ctrl+ Shift + Esc by pressing the keys simultaneously to open the Task Manager tool. Alternatively, you can use the keyboard shortcut Ctrl+Alt+Del and select the Task Manager in blue fullscreen mode, which will appear with several options. You can also find it in the Start menu.

Click “More Details” in the lower left part of the window to expand the Task Manager and find the “Update Agent” process. " (Agent.exe ). It should be right under the background processes. Select it and select the Finish Task option in the lower right part of the window.
Click Yes to display


Hello [Nicholai]

we gotta typo on there, it is not “Waiting on another update”
it says: "“Waiting on another Payment/Deposit”

we very sorry

1 Like

This issue led me to uninstalling and trying again but now the launcher wont even instal properly.

1 Like

Thank you! This worked!

this worked for me, thank you! :black_heart:

This worked for as well. Thank you. Just to add one thing, what you can expect to happen. Once the End Task has done its work and the Update Agent is gone in a few seconds it will pop in again but this time it should be updating, confirmed by a Windows pop up saying Diablo IV has started an update.
Thanks again!

This worked for me:
close the launcher
run as administrator

1 Like

m8 idont know how to find it out this one but yes its worked for me too… ty and goodjob o7

It worked! It wasn’t updating after today’s new patch came out but this method worked. Thanks you’re a life saver!

cheers this worked.
For those confused, its not Finish Task option, its End Task, basically click it and delete will work as well.

It seems like Agent.exe thats responsible for updating gets stuck in a loop, you can even notice 7-10% cpu usage (12900k).

Thank you for saving my life

This worked for me also, except under “Update Agent” (on my Windows 11), the option is “End Task”. After ending the Update Agent task, I started Battlenet and I was able to update my games.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.