Cannot connect to Battle.net

I have fixed the problem myself, so please anyone all you have to do if you get the same problem, please hold down the reset button on your modem for 15 seconds and let it load back up and it will work, please let me know if it helps anyone else

Since yesterday I haven’t been able to connect to battle.net (blizzard Servers) thru my home wifi, but if i jump onto personal hotspot it does connect , i have tried all the support from clearing DNS, resetting internet thru settings, turning of modem, port forwarding, WinMTR scan , different account. and even my xbox doesnt connect to the Blizzard servers, once game has loaded i get the same message (cant connect to online) this has been like this going on the second day and on the forums i am reading the same is happening to many more people.

Is there any fixes that have worked for people or any Dev’s able to help me run thru this, i am in Australia so i cant wait for the live chat to open (5am for me) a quick reply is the best reply so please get back to me ASAP

I uninstalled Battle.net (which didnt uninstall thru my home wifi) i had to use my hotspot and then it worked instantly, and I reconnected to my home wifi to download battle.net and install it. the download worked fine but i left my pc for 2+ hours to install and nothing happened, nothing moved so i re connected to personal hotspot and boom works instantly. i have had firewall turned off aswell

https: // pastebin. com/arpKWgjd

above is my WinMTR scan , i left for 10 mintues before i connected to my personal hotspot again.

also on a side note, when i log into my account thru battle.net launcher. if i type in my password wrong it will tell me instantly my password is incorrect (and yes i have tried different locations USA, ASIA, EU, CHINA) but if i do my password correct it will load for 1, 2 minutes before saying cant connect to servers (could not log in to Battle.net)
/error/BLZBNTBGS80000011