Bnet button is grey


#1

I open my wc3 tft game and the bnet button is grey. I try to flush dns and wintrim and nothing.


#2

Same here in Denmark CPH.


#3

Same here.
I started wc3 with admin, version is up to date, no asking for updates or something. Internet connection is totally fine and was checked.
Nothing was changed, yesterday (same setup) worked fine.

edit: lauchnd wc3 about 15min and now the button is clickable and not grey out anymore.
So i tried to close wc3 again to see if it working now. Restarted and it is grey out again… im about 3 min in so may be in bnet in 12 min now…


#4

We’ve seen this issue when the connection is not stable or slower than normal. Note this doesn’t mean it’s your home connection routing issues may play a role here as well. Leaving the menu screen alone for 10+ minutes the battle.net button will load. General connection troubleshooting may help resolve this issue:

  • Power Cycle home network’s modem and router following the steps Here.
  • Flush your DSN cache using the commands Here.
  • Make sure OS and Firewall ports are open for the game Here.
  • Make sure any third-party anti-virus or firewall software on the system are setup to exclude the game or handle it as a save application.

Thank you!


#5

thanks for your answer. at least wc3 is playable after 10min but got the same error after checking the points you noticed.

will see if it goes away like it commes :wink:

edit:
like i guessed the error is gone with no changes. Everything is normal now the button is insta. clickable.
If you guys have something to do with that i wanna say: big thanks to you support guys!


#6

Hi,
Sometimes i just go in options, wait a bit, come back to home screen and get battle net button to turn blue.
Regards.